Udostępnij za pośrednictwem


Folder Exchange UnifiedContent wypełnia dysk

Symptomy

Alerty dotyczące niskiego miejsca na dysku, na którym jest zainstalowany program Microsoft Exchange Server, a otwieranie plików i aplikacji na tym dysku trwa dłużej. Podczas sprawdzania rozmiaru folderu %ExchangeInstallPath%\TransportRoles\data\Temp\UnifiedContent okazuje się, że używa większości miejsca na dysku.

Przyczyna

Program Exchange Server tworzy pliki tymczasowe w folderze UnifiedContent i zarządza nimi w celu ułatwienia skanowania oprogramowania chroniącego przed złośliwym kodem. Mimo że usługa Microsoft Exchange Health Manager uruchamia zaplanowane zadanie oczyszczania w tym folderze, jeden z następujących scenariuszy może spowodować niepowodzenie oczyszczania:

  • Nie zainstalowano programu Exchange Server w lokalizacji domyślnej (C:\Program Files\Microsoft\Exchange Server\V15). W związku z tym folder UnifiedContent nie istnieje w lokalizacji domyślnej (C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\data\Temp\UnifiedContent).

  • Zmieniono domyślną lokalizację folderu UnifiedContent , bezpośrednio edytując TemporaryStoragePath plik konfiguracji %ExchangeInstallPath%\Bin\EdgeTransport.exe.config lub uruchamiając polecenie Move-TransportDatabase.ps1.

Oczyszczanie kończy się niepowodzeniem, jeśli program Exchange Health Manager nie może zlokalizować folderu UnifiedContent . Lokalizacja folderu UnifiedContent jest określona w CleanupFolderResponderFolderPaths pliku ustawień %ExchangeInstallPath%\Bin\Monitoring\Config\Antimalware.xml. Niezależnie od rzeczywistej ścieżki instalacji programu Exchange Server, CleanupFolderResponderFolderPaths zawiera domyślną ścieżkę instalacji folderu UnifiedContent (C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\data\Temp\UnifiedContent).

Rozwiązanie

Użyj jednej z poniższych rozwiązań, aby zaktualizować ścieżkę folderu UnifiedContent w Antimalware.xml.

Ważne

Jeśli aktualizacja zbiorcza programu Exchange Server zastępuje zmiany w Antimalware.xml, uruchom ponownie wybrane rozwiązanie po zakończeniu aktualizacji.

Rozwiązanie 1

Na każdym serwerze z uruchomionym programem Exchange Server w organizacji wykonaj następujące kroki, aby wskazać menedżera kondycji programu Exchange do folderu UnifiedContent :

Uwaga 16.

Jeśli utworzysz kopię zapasową pliku ustawień Antimalware.xml , zapisz plik kopii zapasowej w innym folderze.

  1. Pobierz ścieżkę folderu UnifiedContent . W tym celu otwórz folder %ExchangeInstallPath%\TransportRoles\data\Temp\UnifiedContent w Eksplorator plików, a następnie skopiuj rozwiniętą ścieżkę folderu.

  2. Otwórz plik ustawień %ExchangeInstallPath%\Bin\Monitoring\Config\Antimalware.xml.

  3. W Antimalware.xml zastąp ścieżkę C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\data\Temp\UnifiedContent w CleanupFolderResponderFolderPathspliku z rozszerzoną ścieżką folderu uzyskaną w kroku 1.

    Jeśli na przykład istniejąca CleanupFolderResponderFolderPaths wartość to D:\ExchangeTemp\TransportCts\UnifiedContent; C:\Windows\Temp\UnifiedContent; C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\data\Temp\UnifiedContent, zmień wartość na D:\ExchangeTemp\TransportCts\UnifiedContent; C:\Windows\Temp\UnifiedContent;<rzeczywista ścieżka> folderu UnifiedContent.

  4. Zapisz zmiany w Antimalware.xml, a następnie uruchom ponownie usługę Programu Exchange Health Manager. Nazwa usługi to MSExchangeHM.

Program Exchange Health Manager czyści folder UnifiedContent podczas następnego cyklu konserwacji. Domyślnie cykle konserwacji są uruchamiane co cztery godziny.

Rozwiązanie 2

Użyj skryptu SetUnifiedContentPath programu PowerShell. Skrypt ustawia CleanupFolderResponderFolderPaths wartość w AntiMalware.xml pliku. Program Exchange Health Manager używa tej wartości do zlokalizowania folderu UnifiedContent do wyczyszczenia.