Udostępnij za pośrednictwem


Aplikacja Poczta systemu Windows nie została zablokowana pomimo ustawień organizacji usługi ActiveSync

Symptomy

Ustawienia Exchange ActiveSync dla organizacji są ustawione tak, aby blokować dostęp do wszystkich urządzeń. Nadal jednak możesz uzyskiwać dostęp do skrzynek pocztowych przy użyciu aplikacji Poczta systemu Windows. Dzieje się tak nawet wtedy, gdy szczegóły urządzenia przenośnego wskazują, że połączenia skrzynki pocztowej nawiązywane przy użyciu poczty systemu Windows zostaną zablokowane.

Użyj następujących metod, aby sprawdzić, czy Exchange ActiveSync jest poprawnie skonfigurowany.

  • Aby sprawdzić ustawienia activesync organizacji:

    Get-ActiveSyncOrganizationSettings | ft DefaultAccessLevel

    Jeśli ustawienie ActiveSync ma blokować urządzenia, to polecenie zwraca następujące dane wyjściowe:

    DefaultAccessLevel : Block

  • Aby sprawdzić urządzenia skonfigurowane do synchronizacji z określoną skrzynką pocztową:

    Get-MobileDeviceStatistics -Mailbox <MailboxID> | fl DeviceUserAgent,DeviceType,deviceos,deviceaccessstate

    To polecenie zwraca następujące dane wyjściowe:

    DeviceType        : UniversalOutlook
    DeviceOS          : WINDOWS
    DeviceAccessState : Unknown
    
  • Aby sprawdzić urządzenia skojarzone z określoną skrzynką pocztową:

    Get-MobileDevice -Mailbox <MailboxID> | fl DeviceUserAgent,DeviceType,deviceos,deviceaccessstate

    To polecenie zwraca następujące dane wyjściowe:

    DeviceUserAgent   : microsoft.windowscommunicationsapps
    DeviceType        : UniversalOutlook
    DeviceOS          : WINDOWS
    DeviceAccessState : Blocked
    

Przyczyna

Aplikacja Poczta systemu Windows korzysta z natywnej technologii synchronizacji firmy Microsoft, która nie jest blokowana przez reguły dostępu urządzeń ActiveSync. Ustawienia activesync organizacji i reguły dostępu urządzeń są używane do zarządzania tylko programem Microsoft Outlook dla połączeń mobilnych i ActiveSync.

Rozwiązanie

Aby zablokować dostęp aplikacji Poczta systemu Windows do skrzynek pocztowych, użyj reguł dostępu klienta lub parametru UniversalOutlookEnabled polecenia cmdlet Set-CASMailbox .