Udostępnij za pośrednictwem


Adresat odrzuca pocztę z Exchange Online lub Exchange Online Protection, a nazwa hosta nie jest zgodna z błędem adresu IP

Oryginalny numer KB: 3019655

Symptomy

Gdy użytkownicy próbują wysłać wiadomość e-mail z usługi Microsoft Exchange Online lub Microsoft Exchange Online Protection do zewnętrznego adresata, docelowy agent transferu wiadomości (MTA) odrzuca wiadomość. Komunikat o błędzie, który otrzymują użytkownicy, może się różnić. Zazwyczaj stwierdza, że nazwa hosta serwera źródłowego nie jest zgodna z jego adresem IP.

Przyczyna

Serwer adresatów wymaga, aby nazwa serwera zawarta w ciągu HELO komunikatu miała odpowiedni rekord zasobu wskaźnika (PTR) (wsteczne wyszukiwanie adresów IP). Exchange Online i Exchange Online Protection wysyłać pocztę przy użyciu wielu adresów IP. Ze względu na ograniczenia DNS nie można mapować wszystkich tych adresów IP za pośrednictwem rekordu PTR na nazwę serwera, która jest w ciągu HELO komunikatu.

Rozwiązanie

Metoda, w której Exchange Online i Exchange Online Protection wysyłać wiadomości e-mail przy użyciu wielu adresów IP, jest typowa dla większości dużych systemów poczty i jest z założenia. Skontaktuj się z administratorem systemu adresatów, aby uzyskać pomoc.

Więcej informacji

W Exchange Online i Exchange Online Protection ustawienia wychodzącej poczty e-mail używają określonych wzorców. Należy pamiętać o tych wzorcach, jeśli serwery adresatów używają wyszukiwań rekordów PTR do weryfikacji. Wynika to z faktu, że wyjaśniają, dlaczego komunikaty wysyłane z usługi mogą zostać odrzucone. Wzorce są następujące:

  1. Adresy IP wysyłające, które są używane przez Exchange Online i Exchange Online Protection, mają potwierdzone do przodu odwrotne rekordy DNS.The sending IP addresses that are used by Exchange Online and Exchange Online Protection have forward-confirmed reverse DNS records. Oznacza to, że każdy wysyłający adres IP ma zarówno rekord DNS przesyłania dalej (nazwa-adres IP), jak i odwrotny rekord DNS (adres-nazwa), który zawiera pasujące informacje. Przykład:

    Outbound IP address: 157.56.110.65
    PTR record: 157.56.110.65 = mail-bn1on0065.outbound.protection.outlook.com
    A-record : mail-bn1on0065.outbound.protection.outlook.com = 157.56.110.65
    
  2. Ciągi HELO/EHLO, które są używane do identyfikowania serwerów poczty używanych przez usługę, również zawierają outbound.protection.outlook.com. Przykład:
    na01-bn1-obe.outbound.protection.outlook.com

    Wszystkie te ciągi HELO/EHLO mają rekordy A zawierające niektóre wychodzące adresy IP odpowiadające serwerom poczty wysyłającej. (Jednak rekordy A nie zawierają wszystkich tych wychodzących adresów IP). Na przykład:
    HELO na01-bn1-obe.outbound.protection.outlook.com

    Rekord: : na01-bn1-obe.outbound.protection.outlook.com

    207.46.163.150
    207.46.163.151
    207.46.163.152
    207.46.163.153
    207.46.163.154
    207.46.163.155
    207.46.163.156
    207.46.163.157
    207.46.163.158
    207.46.163.149

  3. Rekordy PTR adresów IP w rekordzie A ciągu EHLO/HELO nie będą zgodne z ciągiem HELO/EHLO serwera poczty wysyłającej. Przykład:
    Rekord PTR: 207.46.163.150: mail-bn1lp0150.outbound.protection.outlook.com

    Zwróć uwagę, że mail-bn1lp0150.outbound.protection.outlook.com wartość nie jest zgodna z .na01-bn1-obe.outbound.protection.outlook.com

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community.