Udostępnij za pośrednictwem


Komunikaty aktualizacji naprawy są wyzwalane przez błędy timezonematchcheck w Exchange Server

Oryginalny numer KB: 3019798

Symptomy

W Exchange Server 2016 r., Exchange Server 2013 r. lub Exchange Server 2010 r. otrzymasz co najmniej jeden komunikat aktualizacji naprawy w systemie iOS 8.x lub iOS 7. urządzenie x. Te komunikaty wskazują, że asystent naprawy kalendarza (CRA) zaktualizował spotkanie.

Treść wiadomości zawiera następujące elementy:

Your meeting was found to be out of date and has been automatically updated.

Updated meeting details:
Meeting Recurrence

Analiza dzienników CRA pokazuje, że proces TimeZoneMatchCheck nie powiódł się:

<CleanGlobalObjectId>040000008200E00074C5B7101A82E00800000000F076BAF92303D001000000000000000010000000F75B1C45DB47C344BF73214BACD3ED66</CleanGlobalObjectId>
<OwnerAppointmentId>-281888802</OwnerAppointmentId>
<Attendees>
<Attendee EmailAddress="jim@tailspintoys.com">
<ConsistencyChecks>
<ConsistencyCheck Type="CanValidateOwnerCheck" Result="Passed">
<Description>Checks whether the counterpart user can be validated or not.</Description>
</ConsistencyCheck>
<ConsistencyCheck Type="ValidateStoreObjectCheck" Result="Passed">
<Description>Calls Validate() on the base calendar item.</Description>
</ConsistencyCheck>
<ConsistencyCheck Type="MeetingExistenceCheck" Result="Passed">
<Description>Checkes whether the item can be found in the owner's calendar or not.</Description>
</ConsistencyCheck>
<ConsistencyCheck Type="MeetingCancellationCheck" Result="Passed">
<Description>Checkes to make sure that the meeting cancellations statuses match.</Description>
</ConsistencyCheck>
<ConsistencyCheck Type="TimeZoneMatchCheck" Result="Failed">
<Description>Checks to make sure that the attendee has correct recurring time zone information with the organizer.</Description>
<Inconsistencies>
<Inconsistency Owner="Attendee" ShouldFix="True" Flag="RecurringTimeZone" />
</Inconsistencies>
</ConsistencyCheck>
<ConsistencyCheck Type="MeetingPropertiesMatchCheck" Result="Passed">
<Description>Checks to make sure that the attendee has the correct critical properties for the meeting.</Description>
</ConsistencyCheck>
</ConsistencyChecks>
<RUMs>
<RUM IsOccurrence="False" Type="Update" Sent="True" Time="DateTime">
<Flags>
<Flag>RecurringTimeZone</Flag>
</Flags>
</RUM>
</RUMs>
</Attendee>
</Attendees>
</Meeting>
<Meeting Subject="Test Recurring TimeZone Meeting" MeetingType="RecurringMaster" StartTime="DateTime" EndTime="DateTime" Organizer="sarah@tailspintoys.com">
<InternetMessageId>&lt;fc699217a05d40dc867c497754df16e5@CLT-EX13-MBX1.tailspintoys.com&gt;</InternetMessageId>

Uwaga

Domyślną lokalizacją dzienników CRA jest %ExchangeInstallPath%\Logging\Calendar Repair Assistant.

Przyczyna

Komunikaty o aktualizacji naprawy spotkania mogą pojawić się w skrzynce odbiorczej uczestnika 12–48 godzin po zaktualizowaniu spotkania przez uczestnika w systemie iOS 8. x lub iOS 7. urządzenie x . Cra próbuje naprawić rozbieżność, która została wprowadzona przez urządzenie z systemem iOS do właściwości strefy czasowej kopii spotkania uczestnika.

Rozwiązanie

Ten problem został rozwiązany w aktualizacji systemu iOS 8.3.

Zastrzeżenie dotyczące innych firm

Produkty innych firm omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, dorozumianych ani żadnego innego rodzaju, w odniesieniu do wydajności lub niezawodności tych produktów.