Nie można migrować lokalnej podstawowej skrzynki pocztowej z archiwum opartym na chmurze do Exchange Online
Symptomy
We wdrożeniu hybrydowym programu Exchange masz lokalną Microsoft Exchange Server podstawową skrzynkę pocztową i chmurową skrzynkę pocztową archiwum w Exchange Online. Próbujesz przeprowadzić migrację lokalnej podstawowej skrzynki pocztowej do Exchange Online przy użyciu polecenia cmdlet New-MigrationBatch lub New-MoveRequest wraz z przełącznikiemPrimaryOnly
. W tym scenariuszu zostanie wyświetlony następujący komunikat o błędzie:
Baza danych archiwum nie jest jawnie ustawiona w skrzynce pocztowej. W związku z tym nie można zezwolić na przenoszenie tylko podstawowe dla tego użytkownika.
Przyczyna
Ten błąd jest wyzwalany przez sprawdzenie poprawności Exchange Online żądania przeniesienia. Błąd może wystąpić, ponieważ masz dwie skrzynki pocztowe archiwum (lokalna skrzynka pocztowa archiwum i skrzynka pocztowa archiwum w chmurze) i mają tę samą wartość parametru ArchiveGuid
. Ta sytuacja nie jest obsługiwana. W związku z tym migracja kończy się niepowodzeniem i generuje błąd, aby uniknąć utraty danych archiwum w lokalnej podstawowej skrzynce pocztowej.
Uwaga: Jedynym obsługiwanym scenariuszem z podziałem archiwum jest lokalna podstawowa skrzynka pocztowa i archiwum skrzynki pocztowej w Exchange Online.
Rozwiązanie
Aby rozwiązać ten problem, wykonaj następujące czynności:
ArchiveGuid
Sprawdź wartość właściwości lokalnych i chmurowych skrzynek pocztowych archiwum:W przypadku lokalnej skrzynki pocztowej archiwum otwórz powłokę zarządzania programu Exchange, a następnie uruchom następujące polecenie cmdlet Get-Mailbox :
Get-Mailbox -Identity <name of affected mailbox> | FL *archive*
W przypadku skrzynki pocztowej archiwum opartego na chmurze połącz się z programem Exchange Online programu PowerShell, a następnie uruchom następujące polecenie cmdlet Get-MailUser:
Get-MailUser -Identity <name of affected mailbox> | FL *archive*
Jeśli obie archiwalne skrzynki pocztowe mają tę samą
ArchiveGuid
wartość właściwości, przejdź do kroku 2. W przeciwnym razie utwórz wniosek o pomoc techniczną.Utwórz kopię zapasową i wyeksportuj lokalną skrzynkę pocztową archiwum do pliku pst:
Wybierzskrzynki>pocztowe adresatów>Więcej opcji ( ) >Eksportuj do pliku PST.
Na stronie Eksportuj do pliku pst wybierz źródłową skrzynkę pocztową, a następnie wybierz pozycję Eksportuj tylko zawartość archiwum> tej skrzynki pocztowejDalej.
Określ ścieżkę do wyeksportowania pliku pst, a następnie wybierz pozycję Next Finish ( Następne>zakończenie).
Aby uzyskać więcej informacji, zobacz create mailbox export requests (Tworzenie żądań eksportu skrzynki pocztowej).
Dodaj domenę skrzynki pocztowej archiwum opartej na chmurze do
ArchiveDomain
właściwości lokalnej podstawowej skrzynki pocztowej, dla których dotyczy problem:Otwórz powłokę zarządzania programu Exchange i uruchom polecenie cmdlet Set-ADUser :
Set-ADUser -Identity <name of affected mailbox> -Add @{msExchArchiveaddress="<domain name of cloud archive>"}
Uruchom polecenie cmdlet,
Get-Mailbox
aby sprawdzić,ArchiveDomain
czy wartość została pomyślnie ustawiona:Get-Mailbox -Identity <name of affected mailbox> | FL *archive*
Aby przeprowadzić migrację lokalnej podstawowej skrzynki pocztowej do Exchange Online, użyj
New-MigrationBatch
polecenia cmdlet lubNew-MoveRequest
razem z przełącznikiemPrimaryOnly
.
Opinia
https://aka.ms/ContentUserFeedback.
Dostępne już wkrótce: W 2024 r. będziemy stopniowo wycofywać zgłoszenia z serwisu GitHub jako mechanizm przesyłania opinii na temat zawartości i zastępować go nowym systemem opinii. Aby uzyskać więcej informacji, sprawdź:Prześlij i wyświetl opinię dla