Udostępnij za pośrednictwem


Program Outlook nie odpowiada, gdy nawiązuje połączenie ze skrzynką pocztową Exchange Online, która została zmigrowana z lokalnego Exchange Server

Oryginalny numer KB: 3012603

Symptomy

Załóżmy, że skrzynki pocztowe są migrowane z lokalnego środowiska Exchange Server do Exchange Online. Gdy użytkownik uruchomi program Outlook w tej sytuacji, zostanie wyświetlony ekran powitalny i zostanie wyświetlona skrzynka odbiorcza użytkownika. Jeśli jednak użytkownik podejmie jakąkolwiek inną akcję w oknie programu Outlook, pasek tytułu zmieni się na Brak odpowiedzi i pozostanie taki przez kilka minut.

Przyczyna

Ten problem występuje, gdy program Outlook próbuje użyć lokalnych serwerów dostępu klienta, do których odwołuje się rejestr klienta lub w obiektach punktu połączenia usługi (SCP), które znajdują się w Active Directory Domain Services (AD DS).

Rozwiązanie

Ważna

Należy rozważnie wykonywać czynności podane w tej sekcji. Niepoprawne zmodyfikowanie rejestru może być przyczyną poważnych problemów. Przed zmodyfikowaniem rejestru należy utworzyć jego kopię zapasową, aby móc przywrócić rejestr na wypadek problemów.

Aby rozwiązać ten problem, ustaw wartość ExcludeSCPLookup wartości DWORD w kluczu HKEY_CURRENT_USER\Software\Microsoft\Office\<x>\Outlook\Autodiscover rejestru na 1. Aby to zrobić, wykonaj następujące kroki.

  1. Zakończ pracę programu Outlook.

  2. Wybierz pozycję Start, wpisz regedit w polu wyszukiwania, a następnie naciśnij klawisz Enter, aby otworzyć Redaktor rejestru.

  3. Odszukaj i wybierz następujący podklucz rejestru:

    HKEY_CURRENT_USER\Software\Microsoft\Office\<x>\Outlook\AutoDiscover

    Uwaga

    W ścieżce <klucza rejestru x> odpowiada zainstalowanej wersji programu Outlook: — w przypadku programu Outlook 2013 <x> to 15.0 — w przypadku programu Outlook 2010 <x> jest to 14.0 — w przypadku programu Outlook 2007 <x> to 12.0

  4. Wykonaj jeden z następujących kroków:

    • ExcludeSCPLookup Jeśli wartość DWORD już istnieje, przejdź do kroku 5.
    • ExcludeSCPLookup Jeśli wartość DWORD nie istnieje, utwórz ją. Aby to zrobić, wykonaj następujące kroki.
      1. W menu Edytuj wskaż pozycję Nowy, a następnie wybierz pozycję WARTOŚĆ DWORD.
      2. Wpisz ExcludeSCPLookup, a następnie naciśnij klawisz Enter.
  5. Kliknij prawym przyciskiem myszy pozycję ExcludeSCPLookup, wybierz pozycję Modyfikuj, wpisz 1 w polu Dane wartości , a następnie wybierz przycisk OK.

  6. Zamknij Redaktor rejestru, a następnie uruchom ponownie program Outlook.

Więcej informacji

Aby uzyskać więcej informacji na temat wartości rejestru automatycznego wykrywania programu Outlook i sposobu wyszukiwania ustawień automatycznego wykrywania w programie Outlook, zobacz Nieoczekiwane zachowanie wykrywania automatycznego, gdy masz ustawienia rejestru w kluczu \Autodiscover.

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community.