Udostępnij za pośrednictwem


Spotkanie pokazuje nieprawidłową strefę czasową dla uczestnika

Symptomy

Zarówno organizator, jak i uczestnik spotkania pracują w tej samej strefie czasowej. Jednak organizator widzi następujący komunikat podczas planowania spotkania w Outlook w sieci Web lub w nowym programie Microsoft Outlook dla systemu Windows:

<Uczestnik> znajduje się w innej strefie czasowej. Użyj Asystenta planowania, aby wybrać czasy w różnych strefach czasowych.

W Asystentze planowania organizator widzi nieprawidłową strefę czasową dla uczestnika.

Uwaga

Jako administrator możesz sprawdzić, czy ustawienia skrzynki pocztowej dla organizatora i uczestnika pokazują tę samą strefę czasową, uruchamiając następujące polecenie cmdlet w programie Exchange Online programu PowerShell:

Get-MailboxCalendarConfiguration -Identity <user> | FL WorkingHoursTimeZone

Przyczyna

Godziny pracy uczestnika programu Outlook w sieci Web i nowego programu Outlook dla systemu Windows są oparte na nieprawidłowej strefie czasowej z powodu uszkodzonych ustawień kalendarza.

Rozwiązanie

Aby rozwiązać ten problem, użyj narzędzia MFCMAPI , aby zresetować godziny pracy uczestnika. Wykonaj poniższe czynności.

Uwaga

Aby skorzystać z poniższej procedury, musisz mieć pełne uprawnienia dostępu do skrzynki pocztowej uczestnika lub być uczestnikiem. Uruchom procedurę na komputerze z systemem Microsoft Windows z zainstalowanym klientem klasycznym programu Outlook i profilem programu Outlook dla skrzynki pocztowej uczestnika.

  1. Wybierzpozycję Konto> pakietu Plik> pakietu OfficeInformacje o programie Outlook, aby określić, czy instalacja programu Outlook w skrzynce pocztowej uczestnika jest wersją 32-bitową, czy 64-bitową.

  2. Pobierz i wyodrębnij najnowszą 32-bitową lub 64-bitową wersję MFCMAPI , aby dopasować ją do instalacji programu Outlook.

    Ważna

    Mimo że edytor MFCMAPI jest obsługiwany, należy zachować ostrożność, jeśli używasz go do zmiany ustawień skrzynki pocztowej. Niepoprawne użycie edytora MFCMAPI może trwale uszkodzić skrzynkę pocztową.

  3. Zamknij program Outlook i Outlook w sieci Web, a następnie uruchom MFCMapi.exe. Jeśli zostanie wyświetlony ekran uruchamiania MFCMAPI, zamknij go.

  4. Wybierz pozycję Opcje narzędzi>, aby otworzyć okno Opcje.

  5. Wybierz obie następujące opcje, a następnie wybierz przycisk OK:

    • Używanie flagi MDB_Online podczas wywoływania procedury OpenMsgStore

    • Używanie flagi MAPI_NO_CACHE podczas wywoływania procedury OpenEntry

  6. Wybierz pozycję Logowanie sesji>, aby otworzyć okno Wybierz profil.

  7. Wybierz profil programu Outlook dla uczestnika, a następnie wybierz przycisk OK.

  8. Kliknij dwukrotnie skrzynkę pocztową uczestnika w kolumnie Nazwa wyświetlana, aby ją otworzyć.

  9. W okienku po lewej stronie przejdź do pozycji Główny kontener>top kalendarza magazynu> informacji.

  10. Kliknij prawym przyciskiem myszy pozycję Kalendarz, a następnie wybierz pozycję Otwórz tabelę skojarzonej zawartości.

  11. Usuń wszystkie wpisy znajdujące się IPM.FlexibleWorkingHours w kolumnie Message Class (Klasa wiadomości ).

  12. Zamknij wszystkie okna MFCMAPI, aby zamknąć aplikację.

  13. Otwórz Outlook w sieci Web lub nowy program Outlook dla systemu Windows, a następnie ustaw godziny pracy dla uczestnika.