Udostępnij za pośrednictwem


"550 5.7.13 STOREDRV. AuthenticationRequiredForPublicFolder" błąd komunikatów wysyłanych do folderu publicznego z włączoną obsługą poczty

Symptomy

Gdy użytkownicy wysyłają wiadomości e-mail do folderu publicznego z włączoną obsługą poczty, otrzymują raport o braku dostarczania (NDR), który zawiera następujący kod i opis:

550 5.7.13 STOREDRV. AuthenticationRequiredForPublicFolder

Część komunikatu NDR, który wspomina o błędzie, przypomina poniższy szczegółowy przykład.

Zrzut ekranu przedstawiający komunikat o błędzie NDR.

Przyczyna

Ten błąd występuje w następujących scenariuszach:

  • Gdy folder publiczny z włączoną obsługą poczty odbiera wiadomości od użytkownika wewnętrznego:

    W tym scenariuszu folder publiczny z włączoną obsługą poczty i użytkownicy wysyłający do niego wiadomości e-mail znajdują się w tej samej organizacji. Użytkownicy wysyłają wiadomości ze udostępnionej skrzynki pocztowej, w której mają prawa dostępu Wyślij jako lub Wyślij w imieniu . Uprawnienia ustawione w folderze publicznym z włączoną obsługą poczty identyfikują tych użytkowników za pomocą domyślnego uprawnienia użytkownika.

  • Gdy folder publiczny z włączoną obsługą poczty odbiera wiadomości od użytkownika zewnętrznego:

    W tym scenariuszu uprawnienia ustawione w folderze publicznym z włączoną obsługą poczty identyfikują tych użytkowników za pomocą uprawnienia użytkownika anonimowego .

W tych scenariuszach nie jest włączone uprawnienie Domyślne ani Uprawnienie anonimowe do tworzenia elementów. W związku z tym żadne uprawnienie nie jest wystarczające do zapisu komunikatów w publicznym magazynie folderów.

Aby sprawdzić wszystkie uprawnienia użytkownika ustawione w folderze publicznym z włączoną obsługą poczty, uruchom polecenie cmdlet Get-PublicFolderClientPermission w następujący sposób:

Get-PublicFolderClientPermission \<name_of_public_folder>

Uwaga: W tym poleceniu cmdlet zastąp <name_of_public_folder> nazwą folderu publicznego z włączoną obsługą poczty.

Oto przykład danych wyjściowych dla folderu publicznego o nazwie PF2:

Zrzut ekranu przedstawiający uprawnienia użytkownika domyślnego i anonimowego.

Rozwiązanie

Aby naprawić ten błąd, wykonaj następujące kroki, aby włączyć domyślne lub anonimowe uprawnienie użytkownika (odpowiednie dla danego scenariusza), aby móc tworzyć elementy w folderze publicznym z włączoną obsługą poczty.

Uwaga: Aby wprowadzić następujące zmiany, musisz mieć uprawnienia administratora.

  1. Połącz się z usługą Exchange Online w programie PowerShell.

  2. Uruchom polecenie cmdlet Add-PublicFolderClientPermission w następujący sposób:

    W przypadku domyślnego uprawnienia użytkownika:

    Add-PublicFolderClientPermission -Identity "\<name_of_public_folder>" -User Default -AccessRights CreateItems
    

    Aby uzyskać uprawnienie użytkownika anonimowego :

    Add-PublicFolderClientPermission -Identity "\<name_of_public_folder>" -User Anonymous -AccessRights CreateItems
    

    Uwaga: W tych poleceniach cmdlet zastąp <name_of_public_folder> nazwą folderu publicznego z włączoną obsługą poczty.