Udostępnij za pośrednictwem


Błąd "ErrorFoldersRestoredDuringMigrationPermanentException" w partii migracji folderu publicznego

Symptomy

Po uruchomieniu zadania wsadowego migracji folderu publicznego zostanie wyświetlony następujący komunikat o błędzie:

ErrorFoldersRestoredDuringMigrationPermanentException

Zrzut ekranu przedstawiający komunikat o błędzie podczas uruchamiania zadania wsadowego migracji folderu publicznego.

Przyczyna

Ten problem występuje, ponieważ operacja przywracania folderu publicznego nie jest obsługiwana podczas migracji rozpoczynających się od parametru ExcludeDumpster . Problem występuje, jeśli zostaną spełnione następujące warunki:

  • Partia migracji folderu publicznego została utworzona przy użyciu parametru ExcludeDumpster .
  • Usunięto usunięte foldery publiczne ze śmietnika w źródle podczas uruchamiania zadania wsadowego migracji.

Rozwiązanie

Aby rozwiązać ten problem, użyj jednej z następujących metod, stosownie do twojej sytuacji.

Metoda 1. Usuwanie odzyskanych folderów publicznych

  1. Zidentyfikuj identyfikatory wpisów odzyskanych folderów. Poniżej przedstawiono sposób sprawdzania raportu i identyfikowania identyfikatorów wpisów.

    Metoda 1. Korzystanie z centrum administracyjnego programu Exchange

    1. W centrum administracyjnym programu Exchange wybierz pozycję Migracja adresatów>.

    2. Wybierz partię migracji, a następnie wybierz pozycję Wyświetl szczegóły w obszarze Stan skrzynki pocztowej.

    3. Wybierz skrzynkę pocztową migracji zakończonej niepowodzeniem, a następnie wybierz pozycję Pobierz raport dla tego użytkownika.

      Zanotuj tożsamość skrzynki pocztowej migracji zakończonej niepowodzeniem. W poniższym przykładzie tożsamość to Skrzynka pocztowa1.

      Zrzut ekranu przedstawiający pobieranie raportu dla nieudanej skrzynki pocztowej.

    4. W raporcie wyszukaj słowo kluczowe "odzyskane", aby znaleźć identyfikatory wpisów odzyskanych folderów. Identyfikator wpisu jest pierwszą wartością danych odzyskanego wpisu folderu, jak pokazano w poniższym przykładzie.

      Zrzut ekranu przedstawiający identyfikator wpisu odzyskanego folderu.

    Metoda 2. Używanie programu PowerShell

    1. Połącz się z usługą Exchange Online w programie PowerShell.

    2. Pobierz nieudane żądanie migracji skrzynki pocztowej folderu publicznego, uruchamiając następujące polecenie cmdlet:

      $failed_req = Get-PublicFolderMailboxMigrationRequest -Status Failed 
      $failed_req
      

      Zanotuj tożsamość skrzynki pocztowej migracji zakończonej niepowodzeniem.

    3. Wyeksportuj statystyki żądania migracji skrzynki pocztowej folderu publicznego zakończone niepowodzeniem do pliku XML, uruchamiając następujące polecenie cmdlet:

      $failed_req | foreach { Get-PublicFolderMailboxMigrationRequestStatistics $_.Identity -IncludeReport -DiagnosticInfo verbose | Export-Clixml "PF_failed_$($_.TargetMailbox)_$($_.RequestGuid).xml" }
      

      Zrzut ekranu przedstawiający polecenie cmdlet do eksportowania statystyk.

      Plik .xml jest tworzony na komputerze, jak pokazano w poniższym przykładzie.

      Zrzut ekranu przedstawiający pobraną ścieżkę .xml pliku.

    4. Zaimportuj plik XML, uruchamiając następujące polecenie cmdlet:

      $failedreport=Import-Clixml "<Path of the xml file>"
      

      Uwaga:$failedreport to zmienna, którą można dostosować. <Ścieżka pliku> XML reprezentuje rzeczywistą ścieżkę.

    5. Pobierz identyfikatory wpisów odzyskanych folderów, $failedreport uruchamiając następujące polecenie cmdlet:

      $failedreport.Report.Entries|where {[string]$_ -like "*recovered*"}|%{[string]$_}
      

      Identyfikator wpisu jest pierwszą wartością danych odzyskanego wpisu folderu, jak pokazano w poniższym przykładzie.

      Zrzut ekranu przedstawiający identyfikator wpisu, który jest pierwszą wartością danych wpisu odzyskanego folderu.

  2. Usuń odzyskany folder publiczny, uruchamiając następujące polecenie cmdlet:

    Remove-PublicFolder -Identity "<EntryID>"
    

    Zastąp symbol zastępczy <EntryID> identyfikatorem wpisu znalezionym w kroku 1. Aby uzyskać więcej informacji na temat tego polecenia cmdlet, zobacz sekcję "Przykłady" w temacie Remove-PublicFolder.

  3. Rozpocznij migrację nieudanej skrzynki pocztowej, uruchamiając następujące polecenie cmdlet:

    Start-MigrationUser "<FailedMailbox>"
    

    Zastąp <symbol zastępczy FailedMailbox> tożsamością skrzynki pocztowej migracji zakończonej niepowodzeniem zanotowanym w kroku 1. Aby uzyskać więcej informacji na temat tego polecenia cmdlet, zobacz Start-MigrationUser.

Metoda 2. Nie określaj parametru ExcludeDumpster

Jeśli nie chcesz usuwać odzyskanych folderów publicznych, uruchom ponownie migrację bez określania parametru ExcludeDumpster .

Więcej informacji

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community.