Udostępnij za pośrednictwem


Użytkownicy monitowali o poświadczenia po dodaniu udostępnionej skrzynki pocztowej jako drugiego konta e-mail programu Exchange w profilu programu Outlook

Oryginalny numer KB: 3184064

Symptomy

Rozpatrzmy następujący scenariusz:

  • Istnieje hybrydowe wdrożenie lokalnych Microsoft Exchange Server i Microsoft Exchange Online na platformie Microsoft 365.
  • Skonfigurowano starsze lokalne foldery publiczne na potrzeby wdrożenia hybrydowego.
  • Tworzysz udostępnioną skrzynkę pocztową znajdującą się w Exchange Online.
  • Uprawnienia pełnego dostępu są przypisywane do co najmniej jednego użytkownika.
  • Użytkownicy dodają udostępnioną skrzynkę pocztową jako drugie konto programu Exchange w istniejącym profilu programu Outlook.

W tym scenariuszu użytkownicy są wielokrotnie monitowane o poświadczenia podczas otwierania programu Outlook.

Przyczyna

Ten problem występuje, ponieważ program Outlook próbuje nawiązać połączenie ze starszymi lokalnymi folderami publicznymi dla udostępnionej skrzynki pocztowej.

Obejście problemu

Aby obejść ten problem, przenieś udostępnioną skrzynkę pocztową do środowiska lokalnego.

Rozwiązanie

Aby rozwiązać ten problem, można włączyć dostęp do folderów publicznych dla użytkowników i wyłączyć dostęp do folderów publicznych dla udostępnionej skrzynki pocztowej. W tym celu połącz się z programem Exchange Online PowerShell i wykonaj następujące kroki:

  1. Włącz dostęp do folderów publicznych dla użytkowników, uruchamiając następujące polecenie cmdlet:

    Set-CASMailbox tony@contoso.com -PublicFolderClientAccess $true
    

    Uwaga

    Ten przykład umożliwia dostęp do folderów publicznych dla użytkownika tony@contoso.com.

  2. Wyłącz dostęp do folderów publicznych dla udostępnionej skrzynki pocztowej, uruchamiając następujące polecenie cmdlet:

    Set-CASMailbox adam@contoso.com -PublicFolderClientAccess $false
    

    Uwaga

    Ten przykład wyłącza dostęp do folderów publicznych dla udostępnionej skrzynki pocztowej adam@contoso.com.

  3. Włącz dostęp do folderów publicznych dla organizacji, uruchamiając następujące polecenie cmdlet:

    Set-OrganizationConfig -PublicFolderShowClientControl $true
    

Więcej informacji

Komunikat o błędzie podobny do poniższego znajduje się w dzienniku usługi dostępu klienta RPC dla tej próby połączenia:

[LoginPermException] "Identyfikator SID użytkownika: IDENTYFIKATOR SID" nie może pełnić roli właściciela obiektu MailUser "/o=ExchangeLabs/ou=Exchange Administrative Group (Group)/cn=Recipients/cn=<User_Identity>" z identyfikatorem SID sid i identyfikatorem MasterAccountSid S-1-5-10 (StoreError=LoginPerm)

Aby uzyskać więcej informacji, zobacz Konfigurowanie starszych lokalnych folderów publicznych dla wdrożenia hybrydowego.

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community lub forów Exchange TechNet.