Udostępnij za pośrednictwem


"Nie można usunąć tej domeny" podczas próby usunięcia domeny z platformy Microsoft 365

Problem

Podczas próby usunięcia domeny z platformy Microsoft 365 przy użyciu programu Windows PowerShell zostanie wyświetlony następujący komunikat o błędzie:

Remove-MsolDomain : Unable to remove this domain. Use Get-MsolUser -DomainName<domain name> to retrieve a list of objects that are blocking removal.
At line:1 char:18
+ Remove-MsolDomain <<<< -DomainName <DomainName>
+ CategoryInfo : OperationStopped: (:) [Remove-MsolDomain], MicrosoftOnlineException
+ FullyQualifiedErrorId : Microsoft.Online.Administration.Automation.DomainNotEmptyException,Microsoft.Online.Administration.Automation.RemoveDomain

Uwaga / Notatka

Moduły Azure AD i MSOnline PowerShell będą wycofane z dniem 30 marca 2024 r. Aby dowiedzieć się więcej, przeczytaj aktualizację na temat wycofania. Po tej dacie obsługa tych modułów jest ograniczona do pomocy dotyczącej migracji do zestawu MICROSOFT Graph PowerShell SDK i poprawek zabezpieczeń. Przestarzałe moduły będą nadal działać do 30 marca 2025 r.

Zalecamy migrację do programu Microsoft Graph PowerShell w celu interakcji z identyfikatorem Entra firmy Microsoft (dawniej Azure AD). W przypadku typowych pytań dotyczących migracji zapoznaj się z często zadawanymi pytaniami dotyczącymi migracji. Uwaga: Wersje 1.0.x usługi MSOnline mogą napotkać zakłócenia po 30 czerwca 2024 r.

Przyczyna

Ten problem występuje, jeśli spełniony jest co najmniej jeden z następujących warunków:

  • Konta użytkowników lub grupy są skojarzone z domeną.
  • Serwery proxy, które odpowiadają domenie dla wszystkich użytkowników z licencją poczty i dla wszystkich grup obsługujących pocztę, nie są usuwane. Platforma Microsoft 365 blokuje usunięcie domeny do momentu usunięcia serwerów proxy odpowiadających domenie.
  • Adresy protokołu inicjowania sesji (SIP) usługi Skype dla firm Online (dawniej Lync Online) są używane przez domenę.

Rozwiązanie

Użyj centrum administracyjnego platformy Microsoft 365, aby usunąć domenę. Menedżer domeny na platformie Microsoft 365 pomoże administratorom usunąć wszelkie zależności blokujące usuwanie domeny bez konieczności korzystania z programu Windows PowerShell.

Aby uzyskać więcej informacji na temat usuwania domeny w centrum administracyjnym platformy Microsoft 365, przejdź do tematu Usuwanie domeny.

Rozwiązywanie problemów z usuwaniem domeny przy użyciu programu Windows PowerShell

Uwaga / Notatka

Poniższe kroki wymagają od administratorów korzystania z programu Windows PowerShell.

Krok 1. Sprawdzanie, czy nazwy użytkowników zawierają nazwę domeny

Uwaga / Notatka

Możesz również utworzyć widok użytkownika, a następnie ustawić domenę na domenę, którą próbujesz usunąć. Użyj tego widoku, aby zanotować nazwy użytkowników, a następnie zmienić nazwy użytkowników, aby domena, o którą chodzi, nie jest częścią nazwy użytkownika.

Aby sprawdzić, czy nazwy użytkowników zawierają nazwę domeny, wykonaj następujące kroki:

  1. Połącz się z identyfikatorem Entra firmy Microsoft przy użyciu modułu Azure Active Directory dla programu Windows PowerShell. W tym celu otwórz moduły Microsoft Entra dla programu Windows PowerShell, wpisz następujące polecenie cmdlet, a następnie naciśnij Enter.
    Connect-MsolService
    
    Wprowadź dane logowania administratora, gdy zostaniesz o nie poproszony.
  2. Uruchom następujące polecenie cmdlet:
    Get-MsolUser -DomainName [Domain] | fl UserPrincipalName  
    
    Na przykład uruchom następujące polecenie, gdzie symbol zastępczy contoso.com reprezentuje domenę, o której mowa:
    Get-MsolUser -DomainName contoso.com | fl UserPrincipalName
    
  3. Sprawdź wyniki, a następnie zmień główną nazwę użytkownika (UPN), aby domena nie była używana. Nazwa UPN jest taka sama jak nazwa użytkownika i właściwość identyfikatora użytkownika. Aby zmienić nazwę UPN, możesz użyć portalu platformy Microsoft 365 lub programu Windows PowerShell. Celem jest brak zwróconych wyników.

Krok 2. Sprawdzanie adresów e-mail

Uwaga / Notatka

  • Ten krok ma zastosowanie tylko wtedy, gdy masz subskrypcję obejmującą usługę Exchange Online.
  • Jeśli używasz narzędzia azure Active Directory Sync, możesz zaktualizować adresy e-mail ze środowiska lokalnego.

Aby sprawdzić adresy e-mail, wykonaj następujące kroki:

  1. Połącz się z usługą Exchange Online przy użyciu zdalnej obsługi programu PowerShell. Aby uzyskać więcej informacji o tym, jak to zrobić, zobacz Connect to Exchange Online Using Remote PowerShell (Nawiązywanie połączenia z usługą Exchange Online przy użyciu zdalnego programu PowerShell).

  2. Znajdź wszystkich użytkowników i grupy używające domeny, którą próbujesz usunąć. W tym celu uruchom następujące polecenie cmdlet. (W tym poleceniu cmdlet contoso.com reprezentuje domenę, o której mowa).

    get-recipient | where {$_.EmailAddresses -match "contoso.com"} | fl Name, RecipientType, EmailAddresses
    
  3. W danych wyjściowych zanotuj wartość właściwości EmailAddresses i właściwości RecipientTypeproperty. Na przykład dane wyjściowe mogą wyglądać podobnie do następujących:

    Name : John Smith RecipientType : UserMailbox EmailAddresses : {SIP:john@contoso.com, SMTP:john@contoso.com,   smtp:john@contoso.onmicrosoft.com}
    
  4. Wykonaj jedną z następujących czynności, zgodnie z potrzebami w twojej sytuacji:

Więcej informacji

Aby uzyskać więcej informacji, zobacz Komunikat o błędzie podczas próby usunięcia domeny z platformy Microsoft 365.

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community.