Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Oryginalny numer KB: 4025591
Symptomy
Spróbuj dodać kalendarz internetowy w programie Microsoft Outlook 2016, Outlook 2019 lub Outlook dla Microsoft 365, wykonując następujące kroki:
- Przejdź do modułu kalendarza.
- W grupie Zarządzaj kalendarzami na pasku narzędzi wybierz pozycję Otwórz kalendarz.
- Wybierz opcję Z Internetu.
- Podaj ścieżkę pliku kalendarza internetowego.
- Wybierz przycisk OK.
Jeśli używasz tej metody dla niektórych serwerów internetowych, kalendarz nie zostanie pomyślnie dodany. Po krótkim otworzeniu okna postępu wrócisz do modułu kalendarza bez dodania nowego kalendarza. Ponadto nie jest wyświetlany żaden komunikat o błędzie.
Przyczyna
Domyślnie programy Outlook 2016, Outlook 2019 i Outlook dla Microsoft 365 używają nowego nowoczesnego stosu uwierzytelniania. Nawet jeśli plik kalendarza internetowego, który próbujesz otworzyć, nie wymaga uwierzytelniania, program Outlook emituje możliwość nowoczesnego uwierzytelniania na serwerze zawierającym kalendarz. Większość oprogramowania serwera reaguje na tę emisję, obsługując nowoczesne uwierzytelnianie. Jednak niektóre serwery uważają emisję za nieprawidłowe żądanie klienta. W związku z tym zwracają odpowiedź, która powoduje anulowanie próby dodania kalendarza przez program Outlook.
Na przykład oprogramowanie serwera uruchomione w usługach Amazon Web Services (AWS) może rozważyć, że emisja uwierzytelniania jest nieprawidłowa i odrzuca połączenie.
Rozwiązanie
Aby obejść ten problem, użyj aplikacji Outlook Web App (OWA). Program OWA nie ma tego zachowania nagłówka uwierzytelniania. W związku z tym otwiera kalendarz internetowy, który chcesz dodać.
Aby dodać kalendarz przy użyciu programu OWA, wykonaj następujące kroki:
- Zaloguj się do aplikacji OWA.
- Przejdź do modułu Kalendarz.
- Wybierz menu Dodaj kalendarz.
- Wybierz opcję Z Internetu.
- Podaj adres URL i opcjonalną nazwę kalendarza.
- Wybierz pozycję Zapisz.
Więcej informacji
Po dodaniu kalendarza internetowego przy użyciu programu OWA serwer z uruchomionym programem Exchange Server zarządza subskrypcją kalendarza i aktualizacjami. Aktualizacje kalendarza są synchronizowane co około cztery godziny.
Kalendarz dodany z aplikacji OWA nie jest wyświetlany w aplikacji klasycznej Outlook jako kalendarz internetowy. Zamiast tego jest on wyświetlany jako wpis kalendarza w grupie Inne kalendarze . Ponieważ żadne informacje o subskrypcji nie są obsługiwane ani kontrolowane przez aplikację klasyczną Outlook, nie musisz konfigurować żadnych opcji kalendarza internetowego po stronie klienta dla kalendarza dodanego za pośrednictwem programu OWA.
Wyłączenie odpowiedzialności za kontakty z osobami trzecimi
Firma Microsoft udostępnia informacje dotyczące sposobów kontaktowania się z innymi firmami, aby ułatwić uzyskanie niezbędnej pomocy technicznej. Informacje te mogą zostać zmienione bez powiadomienia. Firma Microsoft nie gwarantuje dokładności informacji dotyczących innych firm.