Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Symptomy
Po wysłaniu wiadomości żądania zadania w programie Outlook żądanie zadania adresata nie zawiera przycisków Akceptuj i Odrzuć ani nie ma czytelnych szczegółów zadania. Ten problem może wystąpić dla adresatów, którzy są wewnętrzni lub zewnętrzni w organizacji programu Microsoft Exchange.
Na przykład żądanie zadania adresata może przypominać poniższy przykład.
Na następnym zrzucie ekranu pokazano, jak powinno wyglądać żądanie zadania.
Przyczyna
Program Outlook wysłał żądanie zadania jako komunikat RTF (Rich Text Format), ale składnik transportu zmienił format wiadomości na HTML. Konwersja na kod HTML usunęła elementy przycisku i przeszuknęła układ komunikatu.
Jeśli adresat jest wewnętrzny w organizacji programu Exchange, konfiguracja programu Exchange może mieć następujące elementy:
- Łącznik ruchu wychodzącego, który kieruje komunikaty za pośrednictwem usługi zewnętrznej. Wewnętrzny przepływ poczty zachowuje format komunikatów RTF, ale usługi zewnętrzne często konwertują komunikaty RTF na html. Na przykład usługi podpisywania i ochrony prywatności konwertują komunikaty RTF na HTML.
Jeśli adresat jest spoza organizacji programu Exchange, konfiguracja programu Exchange może mieć jedną z następujących wartości:
Łącznik ruchu wychodzącego, który kieruje komunikaty za pośrednictwem usługi zewnętrznej, która zmienia format komunikatu na HTML.
Ustawienie domeny
TNEFEnabled
zdalnej, które konwertuje wychodzące komunikaty RTF na html.
Rozwiązanie
Aby rozwiązać ten problem, sprawdź następujące ustawienia, a następnie wprowadź odpowiednie zmiany:
W przypadku adresatów wewnętrznych i zewnętrznych sprawdź, czy łącznik wychodzący kieruje komunikaty za pośrednictwem usługi zewnętrznej. Jeśli tak, rozważ dodanie wyjątku do reguły przepływu poczty, która kieruje komunikaty do tego łącznika. Można na przykład wykluczyć komunikaty żądania zadania z kierowania za pośrednictwem usług zewnętrznych, tworząc wyjątek dla komunikatów, które mają temat rozpoczynający się od "
Task request:
".W przypadku adresatów zewnętrznych sprawdź
TNEFEnabled
ustawienie dla wszystkich domen zdalnych. Aby to zrobić, uruchom następujące polecenie:Get-RemoteDomain | Where {$_.TNEFEnabled -ne $true}
TNEFEnabled
Jeśli ustawienie dla domeny zdalnej to $null
lub $false
, program Exchange przekonwertuje komunikaty RTF na html dla adresatów w tej domenie. Jeśli na przykład TNEFEnabled
ustawienie domyślnej domeny zdalnej to $null
, a jeśli jest to jedyna domena zdalna, program Exchange przekonwertuje wszystkie zewnętrzne komunikaty RTF na html. Aby rozwiązać problem dla adresata zewnętrznego, którego dotyczy problem, wykonaj następujące kroki:
Utwórz domenę zdalną dla domeny adresata zewnętrznego, którego dotyczy problem.
Ustaw
TNEFEnabled
wartość na$true
dla tej domeny, uruchamiając następujące polecenie:Set-RemoteDomain -Identity <name of the new remote domain> -TNEFEnabled $true
Uwaga 16.
Unikaj ustawienia TNEFEnabled
$true
w domyślnej domenie zdalnej, ponieważ ta zmiana wpłynie na wszystkich adresatów zewnętrznych, w tym tych, których klient poczty e-mail może nie obsługiwać wiadomości RTF.