Jak pisać i uruchamiać skrypty w środowisku Windows PowerShell ISE

W tym artykule opisano sposób tworzenia, edytowania, uruchamiania i zapisywania skryptów w okienku skryptów.

Jak tworzyć i uruchamiać skrypty

Pliki Windows PowerShell można otwierać i edytować w okienku skryptu. Określone typy plików, których interesuje Windows PowerShell to pliki skryptów (.ps1), pliki danych skryptu (.psd1) i pliki modułów skryptu (.psm1). Te typy plików są kolorami składni w edytorze okienka skryptów. Inne typowe typy plików, które można otworzyć w okienku skryptu, to pliki konfiguracji (.ps1xml), pliki XML i pliki tekstowe.

Uwaga

Zasady wykonywania Windows PowerShell określają, czy można uruchamiać skrypty i ładować profile Windows PowerShell i pliki konfiguracji. Domyślne zasady wykonywania, Ograniczone, zapobiega uruchamianiu wszystkich skryptów i uniemożliwiają ładowanie profilów. Aby zmienić zasady wykonywania, aby umożliwić ładowanie i używanie profilów, zobacz Set-ExecutionPolicy i about_Signing.

Aby utworzyć nowy plik skryptu

Na pasku narzędzi kliknij pozycję Nowy lub w menu Plik kliknij pozycję Nowy. Utworzony plik zostanie wyświetlony na nowej karcie pliku na bieżącej karcie programu PowerShell. Pamiętaj, że karty programu PowerShell są widoczne tylko wtedy, gdy istnieje więcej niż jedna karta. Domyślnie tworzony jest plik skryptu typu (.ps1), ale można go zapisać przy użyciu nowej nazwy i rozszerzenia. Na tej samej karcie programu PowerShell można utworzyć wiele plików skryptów.

Aby otworzyć istniejący skrypt

Na pasku narzędzi kliknij polecenie Otwórz lub w menu Plik kliknij pozycję Otwórz. W oknie dialogowym Otwieranie wybierz plik, który chcesz otworzyć. Otwarty plik zostanie wyświetlony na nowej karcie.

Aby zamknąć kartę skryptu

Kliknij ikonę Zamknij (X) karty plik, którą chcesz zamknąć, lub wybierz menu Plik , a następnie kliknij przycisk Zamknij.

Jeśli plik został zmieniony od czasu ostatniego zapisania, zostanie wyświetlony monit o zapisanie lub odrzucenie go.

Aby wyświetlić ścieżkę pliku

Na karcie Plik wskaż nazwę pliku. W pełni kwalifikowana ścieżka do pliku skryptu jest wyświetlana w etykietce narzędzia.

Aby uruchomić skrypt

Na pasku narzędzi kliknij polecenie Uruchom skrypt lub w menu Plik kliknij polecenie Uruchom.

Aby uruchomić część skryptu

  1. W okienku Skrypt wybierz część skryptu.
  2. W menu Plik kliknij polecenie Uruchom zaznaczenie lub na pasku narzędzi kliknij polecenie Uruchom zaznaczenie.

Aby zatrzymać uruchomiony skrypt

Istnieje kilka sposobów zatrzymania uruchomionego skryptu.

  • Kliknij pozycję Zatrzymaj operację na pasku narzędzi
  • Naciśnij klawisze CTRL+BREAK
  • Wybierz menu Plik i kliknij polecenie Zatrzymaj operację.

Naciśnięcie klawisza CTRL+C również działa, chyba że jakiś tekst jest aktualnie zaznaczony, w tym przypadku ctrl+C mapuje na funkcję copy dla zaznaczonego tekstu.

Jak napisać i edytować tekst w okienku skryptów

W okienku skryptów można kopiować, wycinać, wklejać, znajdować i zamieniać tekst. Możesz również cofnąć i ponownie wykonać ostatnią wykonaną akcję. Skróty klawiaturowe dla tych akcji są tymi samymi skrótami używanymi dla wszystkich aplikacji systemu Windows.

Aby wprowadzić tekst w okienku skryptu

  1. Przenieś kursor do okienka skryptów, klikając dowolne miejsce w okienku skryptu lub klikając pozycję Przejdź do okienka skryptów w menu Widok .
  2. Utwórz skrypt. Kolorowanie składni i uzupełnianie kart zapewniają bogatsze środowisko edycji w środowisku Windows PowerShell ISE.
  3. Aby uzyskać szczegółowe informacje na temat używania funkcji uzupełniania kart w okienku skryptu i okienku konsoli, zobacz Jak używać funkcji uzupełniania kart, aby ułatwić wpisywanie.

Aby znaleźć tekst w okienku skryptu

  1. Aby znaleźć tekst w dowolnym miejscu, naciśnij klawisze CTRL+F lub w menu Edycja kliknij przycisk Znajdź w skry skrycie.
  2. Aby znaleźć tekst po kursorze, naciśnij klawisz F3 lub w menu Edycja kliknij przycisk Znajdź dalej w skrycie.
  3. Aby znaleźć tekst przed kursorem, naciśnij klawisze SHIFT+F3 lub w menu Edycja kliknij przycisk Znajdź poprzedni skrypt.

Aby znaleźć i zamienić tekst w okienku skryptu

Naciśnij klawisze CTRL+H lub w menu Edycja kliknij polecenie Zamień w skrypcie. Wprowadź tekst, który chcesz znaleźć, i tekst zastępczy, a następnie naciśnij klawisz ENTER.

Aby przejść do określonego wiersza tekstu w okienku skryptu

  1. W okienku Skrypt naciśnij klawisze CTRL+G lub w menu Edycja kliknij pozycję Przejdź do wiersza.

  2. Wprowadź numer wiersza.

Aby skopiować tekst w okienku skryptu

  1. W okienku Skrypt wybierz tekst, który chcesz skopiować.

  2. Naciśnij klawisze CTRL+C lub na pasku narzędzi kliknij ikonę Kopiuj lub w menu Edycja kliknij polecenie Kopiuj.

Aby wyciąć tekst w okienku skryptu

  1. W okienku Skrypt wybierz tekst, który chcesz wyciąć.
  2. Naciśnij klawisze CTRL+X lub na pasku narzędzi kliknij ikonę Wytnij lub w menu Edycja kliknij polecenie Wytnij.

Aby wkleić tekst do okienka skryptów

Naciśnij klawisze CTRL+V lub na pasku narzędzi kliknij ikonę Wklej lub w menu Edycja kliknij przycisk Wklej.

Aby cofnąć akcję w okienku skryptu

Naciśnij klawisze CTRL+Z lub na pasku narzędzi, kliknij ikonę Cofnij lub w menu Edycja kliknij przycisk Cofnij.

Aby ponownie przeprowadzić akcję w okienku skryptu

Naciśnij klawisze CTRL+Y lub na pasku narzędzi kliknij ikonę Wykonaj ponownie lub w menu Edycja kliknij przycisk Wykonaj ponownie.

Jak zapisać skrypt

Gwiazdka pojawia się obok nazwy skryptu, aby oznaczyć plik, który nie został zapisany od czasu jego zmiany. Gwiazdka zniknie po zapisaniu pliku.

Aby zapisać skrypt

Naciśnij klawisze CTRL+S lub na pasku narzędzi kliknij ikonę Zapisz lub w menu Plik kliknij przycisk Zapisz.

Aby zapisać skrypt i nadać jego nazwę

  1. W menu File (Plik) kliknij pozycję Save As (Zapisz jako). Zostanie wyświetlone okno dialogowe Zapisz jako .
  2. W polu Nazwa pliku wprowadź nazwę pliku.
  3. W polu Zapisz jako typ wybierz typ pliku. Na przykład w polu Zapisz jako typ wybierz pozycję "Skrypty programu PowerShell (*.ps1)".
  4. Kliknij pozycję Zapisz.

Aby zapisać skrypt w kodowaniu ASCII

Domyślnie program Windows PowerShell ISE zapisuje nowe pliki skryptów (.ps1), pliki danych skryptu (.psd1) i pliki modułów skryptu (.psm1) jako Unicode (BigEndianUnicode). Aby zapisać skrypt w innym kodowaniu, takim jak ASCII (ANSI), użyj metod Save lub SaveAs w obiekcie $psISE.CurrentFile .

Następujące polecenie zapisuje nowy skrypt jako MyScript.ps1 z kodowaniem ASCII.

$psISE.CurrentFile.SaveAs("MyScript.ps1", [System.Text.Encoding]::ASCII)

Następujące polecenie zastępuje bieżący plik skryptu plikiem o tej samej nazwie, ale kodowaniem ASCII.

$psISE.CurrentFile.Save([System.Text.Encoding]::ASCII)

Następujące polecenie pobiera kodowanie bieżącego pliku.

$psISE.CurrentFile.encoding

Windows PowerShell ISE obsługuje następujące opcje kodowania: ASCII, BigEndianUnicode, Unicode, UTF32, UTF7, UTF8 i Default. Wartość opcji Domyślne różni się w zależności od systemu.

Windows PowerShell ISE nie zmienia kodowania plików skryptów podczas korzystania z poleceń Zapisz lub Zapisz jako.

Zobacz też