Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Ostrzeżenie
Wycofana, nieobsługiwana aplikacja klasyczna Internet Explorer 11 ma zostać trwale wyłączona za pośrednictwem aktualizacji aplikacji Microsoft Edge dla niektórych wersji systemu Windows 10. Aby uzyskać więcej informacji, zobacz artykuł pt. Często zadawane pytania dotyczące wycofywania aplikacji klasycznej Internet Explorer 11.
W tym artykule opisano sposób rozwiązywania problemu, w którym przeglądarki lub aplikacje korzystające z modułów przeglądarki próbują uzyskać dostęp do plików należących do profilu administratora komputera oprócz plików należących do profilu bieżącego użytkownika.
Oryginalna wersja produktu: Internet Explorer, Windows 10; Microsoft Edge, Windows 10
Symptomy
Użytkownicy korporacyjni programów Internet Explorer, Microsoft Edge lub aplikacji korzystających z modułów przeglądarki zgłaszają następujące objawy:
- Długie opóźnienia występują, gdy użytkownicy loguje się do pulpitu systemu Windows.
- Aplikacja nie może zapisać zawartości w pamięci podręcznej przeglądarki.
- Aplikacja nie może uzyskać dostępu do zawartości z pamięci podręcznej przeglądarki.
W tym scenariuszu użytkownik, którego dotyczy problem, rejestruje dziennik monitora procesów podczas wystąpienia problemu. Podczas analizowania dziennika zauważysz, że przeglądarki lub aplikacje próbują uzyskać dostęp do plików i folderów znajdujących się w folderze C:\Users\Administrator oprócz plików i folderów znajdujących się w folderze profilu użytkownika.
Przyczyna
Przy pierwszym logowaniu użytkownika do systemu Windows system używa informacji z domyślnego profilu użytkownika w celu skonfigurowania nowego profilu użytkownika. System Windows tworzy również kontener pamięci podręcznej w ramach profilu użytkownika, dla przeglądarek i innych aplikacji do użycia.
Ten problem z dostępem może wystąpić, jeśli domyślny profil użytkownika został zmieniony w celu utworzenia ustawień niestandardowych dla nowych profilów użytkowników. dotyczy to szczególnie, jeśli proces modyfikacji obejmuje kopiowanie informacji o profilu z profilu administratora. W szczególności niektóre narzędzia do tworzenia obrazów lub wdrażania kopiują część lub całą zawartość profilu administratora do domyślnego profilu użytkownika.
Profil administratora ma własny kontener pamięci podręcznej. Jeśli ta część profilu administratora zostanie skopiowana do domyślnego profilu użytkownika, nowi użytkownicy otrzymają kopię kontenera pamięci podręcznej administratora zamiast nowego kontenera pamięci podręcznej. Konto Administratora jest właścicielem kontenera cache. Konto użytkownika nie istnieje. W związku z tym użytkownik nie ma pełnego dostępu do kontenera pamięci podręcznej.
Rozwiązanie
Na komputerach, których dotyczy problem, należy osobno naprawić profil użytkownika, którego dotyczy problem, i domyślny profil użytkownika.
Uwaga
Zdecydowanie zalecamy wykonanie kopii zapasowej wszystkich lokalizacji folderów profilu lub wpisów rejestru przed wprowadzeniem jakichkolwiek modyfikacji.
Uwaga
Domyślnie te pliki profilów i foldery są ukryte przed widokiem. Aby były widoczne, należy tymczasowo zmienić opcje widoku folderu folderu C:\Users\Default i folderu C:\Users\<user name> (w którym nazwa<dotyczy problem). W tym celu wykonaj następujące kroki:
- Otwórz Eksplorator plików systemu Windows i znajdź odpowiednią lokalizację folderu profilu.
- Wybierz Widok>Opcje>Widok.
- Na liście Ustawienia zaawansowane wybierz pozycję Pokaż ukryte pliki, foldery i dyski.
- Na tej samej liście wyczyść pole wyboru Ukryj chronione pliki systemu operacyjnego (zalecane), a następnie wybierz pozycję Tak.
- Wybierz pozycję Zastosuj>OK.
Krok 1. Naprawianie domyślnego profilu użytkownika
Aby uniemożliwić nowym profilom użytkowników odbieranie kopii kontenera pamięci podręcznej z domyślnego profilu użytkownika, usuń następujący plik i foldery (jeśli istnieją):
- C:\Users\Default\AppData\Local\Microsoft\Windows\WebCacheLock.dat
- C:\Users\Default\AppData\Local\Microsoft\Windows\WebCache
- C:\Users\Default\AppData\Local\Microsoft\Windows\INetCache
- C:\Users\Default\AppData\Local\Microsoft\Windows\INetCookies
Krok 2. Naprawianie każdego profilu użytkownika, którego dotyczy problem
Nie można usunąć kilku plików i folderów należących do profilu użytkownika, gdy użytkownik jest zalogowany w systemie Windows. Ze względu na to ograniczenie użytkownik musi wylogować się z systemu Windows, a następnie administrator może zalogować się i naprawić profil. Aby naprawić profil, usuń następujący plik i foldery (jeśli istnieją):
C:\Users\<user name>\AppData\Local\Microsoft\Windows\WebCacheLock.dat
C:\Users\<user name>\AppData\Local\Microsoft\Windows\WebCache
C:\Users\<user name>\AppData\Local\Microsoft\Windows\INetCache
C:\Users\<user name>\AppData\Local\Microsoft\Windows\INetCookies
Uwaga
W tych ścieżkach plików nazwa<którego dotyczy problem.
Po usunięciu tych elementów wykonaj następujące kroki:
- Przywróć opcje widoku folderu do poprzednich wartości.
- Uruchom ponownie komputer, a następnie zaloguj się użytkownika, którego dotyczy problem (lub możesz zalogować się przy użyciu nowego konta użytkownika).
Więcej informacji
Pliki i foldery wymienione w tym artykule składają się na część pamięci podręcznej przeglądarki Internet Explorer i Przeglądarki Microsoft Edge. Te lokalizacje zawartości są przeznaczone do tworzenia dla każdego użytkownika osobno. Dlatego zalecamy, aby nie próbować ich dostosowywać, zmieniać ani przenosić. Nie popieramy tego.