Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Ten artykuł zawiera rozwiązanie błędów występujących podczas przeglądania dziennika aplikacji na komputerze z uruchomionymi usługami Microsoft Dynamics AX 4.0 Application Object Server (AOS).
Dotyczy: Microsoft Dynamics AX
Oryginalny numer KB: 937873
Objawy
Podczas przeglądania dziennika aplikacji na komputerze z uruchomionymi usługami Microsoft Dynamics AX 4.0 Application Object Server (AOS) mogą zostać wyświetlone komunikaty o błędach podobne do następujących:
Komunikat o błędzie 1
Typ zdarzenia:Informacje
Źródło zdarzenia: Dynamics Server 17
Data:7/4/2007
Godzina: 12:30:14 po południu
Kategoria zdarzenia: Brak
Opis rozwiązania:
Object Server 01: Błąd RPC: wyjątek RPC 1726 wystąpił w sesji 10
Komunikat o błędzie 2
Typ zdarzenia:Informacje
Źródło zdarzenia: Dynamics Server 01
Kategoria zdarzenia: Brak
Identyfikator zdarzenia:110
Data:7/4/2007
Czas: 00:30:33
Użytkownik:N/A
Komputer: ComputerName
Opis rozwiązania:
Object Server 01: Brak odpowiedzi ping z 10. Kończenie sesji.
Pierwszy komunikat o błędzie może być skojarzony z drugim komunikatem o błędzie. Dopóki serwer systemu AOS nie zakończy sesji 10, każda sesja zwracająca komunikaty o błędach RPC przestanie odpowiadać. Jeśli zbyt wiele sesji przestanie odpowiadać i zwraca komunikaty o błędach RPC, serwer AOS może zostać zamknięty.
Przyczyna
Ten problem może wystąpić, ponieważ użytkownicy opuszczają program Microsoft Dynamics AX niewłaściwie. Na przykład użytkownicy kończą proces Microsoft Dynamics AX przy użyciu Menedżera zadań.
RPC 1726 jest ogólnym komunikatem o błędzie połączenia. Jednak komunikat o błędzie RPC 1726 może być skojarzony z komunikatem o błędzie Brak polecenia ping z 10. Zakończenie sesji. W takim przypadku problem jest zwykle spowodowany tym, że użytkownicy niepoprawnie wyłączają system Microsoft Dynamics AX.
Rozwiązanie
Jeśli wystąpi ten problem na kliencie Microsoft Dynamics AX, nie zamykaj klienta, naciskając Ctrl+Alt+Del. Zalecamy używanie Ctrl+Break, a następnie oczekiwanie na ponowne reagowanie systemu lub skontaktowanie się z administratorem programu Microsoft Dynamics AX lub innym użytkownikiem, który ma uprawnienia do formularza użytkowników online. Administrator lub inny użytkownik może wybrać opcję Zakończ sesję , aby zamknąć sesję klienta.
Więcej informacji
Jeśli wystąpi ten problem na serwerze systemu AOS, ważne jest, aby określić, która sesja jest przyczyną i co użytkownicy robią, aby spowodować problem.
Aby to zrobić, wykonaj następujący skrypt:
select * from sysuserlog where logouttime = 0 and sessionid = <X>
Uwaga
Zastąp element <X> sesją wskazaną w komunikacie o błędzie RPC. W wynikach zapytania zwróć uwagę na kolumny USERID i COMPUTERNAME . Wartości kolumn wskazują, kto loguje się i skąd.
Zazwyczaj wyjątki RPC są powodowane przez nieprawidłowe zamknięcie aplikacji. Jednak wyjątki mogą również wskazywać, że proces biznesowy zawiesza się lub trwa długo.
Odnośniki
Aby uzyskać więcej informacji, zobacz Jak znaleźć identyfikator użytkownika skojarzony z identyfikatorem sesji w komunikacie o błędzie w dzienniku aplikacji na serwerze AOS w Microsoft Dynamics AX: "Błąd RPC: wyjątek RPC 1726 wystąpił w sesji <SessionID>".