Udostępnij za pośrednictwem


Wystąpił błąd personifikacji podczas łączenia Dynamics 365 firmy Microsoft z Exchange Server lokalnym

Ten artykuł zawiera rozwiązanie problemu, w którym może wystąpić błąd informujący o błędzie personifikacji podczas uzyskiwania dostępu do skrzynki pocztowej podczas wysyłania wiadomości e-mail "Wiadomość testowa" podczas próby włączenia skrzynki pocztowej.

Dotyczy: Microsoft Dynamics CRM
Oryginalny numer KB: 3189639

Symptomy

Po skonfigurowaniu synchronizacji Server-Side między usługą Microsoft Dynamics 365 (online) i Microsoft Exchange Server (lokalnie) po próbie włączenia skrzynki pocztowej zostanie wyświetlony jeden z następujących błędów:

Wystąpił błąd personifikacji podczas uzyskiwania dostępu do skrzynki pocztowej podczas wysyłania wiadomości e-mail "Wiadomość testowa". Nazwa> skrzynki <pocztowej nie została zsynchronizowana. Właściciel skojarzonego profilu <serwera poczty e-mail Email nazwa> profilu serwera został powiadomiony.

Wystąpił błąd personifikacji podczas uzyskiwania dostępu do skrzynki pocztowej podczas odbierania wiadomości e-mail. <Nazwa> skrzynki pocztowej nie została zsynchronizowana. Właściciel skojarzonego profilu <serwera poczty e-mail Email nazwa> profilu serwera został powiadomiony.

Po wybraniu pozycji Szczegóły dla jednego z błędów wymienionych powyżej mogą zostać wyświetlone szczegóły, takie jak:

ActivityId: <IDENTYFIKATOR GUID>
>Błąd: System.Web.Services.Protocols.SoapException: Konto nie ma uprawnień do personifikacji żądanego użytkownika.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
w: System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
w: Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndFindItem(IAsyncResult asyncResult)
w: Microsoft.Crm.Asynchronous.EmailConnector.FindItemsStep.EndCall()
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation()ActivityId: <GUID>
>Błąd: System.Web.Services.Protocols.SoapException: Konto nie ma uprawnień do personifikacji żądanego użytkownika.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
w: System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
w: Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult)
w: Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()

Przyczyna

Ten błąd może wystąpić, jeśli konto użytkownika określone w celu uzyskania dostępu do skrzynki pocztowej nie ma uprawnień personifikacji dla skrzynki pocztowej. Konto używane do uzyskiwania dostępu do skrzynki pocztowej jest udostępniane w ramach rekordu profilu serwera Email skojarzonego z rekordem skrzynki pocztowej w usłudze Microsoft Dynamics 365.

Rozwiązanie

Upewnij się, że konto użytkownika podane w rekordzie profilu serwera Email ma uprawnienia personifikacji do każdej skojarzonej skrzynki pocztowej. W ramach rekordu skrzynki pocztowej w usłudze Microsoft Dynamics 365 możesz wybrać wartość Profil serwera i sprawdzić, które konto jest udostępniane w sekcji Poświadczenia rekordu profilu serwera Email.

Aby uzyskać więcej informacji na temat konfigurowania personifikacji programu Exchange, zobacz: