Nie można nawiązać połączenia z Dynamics 365 (online), wersja 9.0 przy użyciu narzędzi zestawu SDK
Ten artykuł zawiera rozwiązanie problemu, w którym nie można nawiązać połączenia z Dynamics 365 (online), wersja 9.0, przy użyciu narzędzi zestawu SDK.
Dotyczy: Microsoft Dynamics CRM
Oryginalny numer KB: 4077479
Symptomy
Nie możesz nawiązać połączenia z Dynamics 365 (online) w wersji 9.0 przy użyciu narzędzi zestawu SDK, takich jak narzędzie do rejestracji wtyczek lub narzędzie do migracji konfiguracji. Po podaniu informacji o połączeniu i wybraniu przycisku Zaloguj się wrócisz do okna dialogowego logowania.
Przyczyna
Może się to zdarzyć, jeśli nie używasz najnowszej wersji narzędzi zestawu SDK korzystających z protokołu TLS 1.2. Dynamics 365 (online), wersja 9.0, wymaga protokołu TLS 1.2 lub nowszego. Protokoły TLS 1.0 i 1.1 nie są już obsługiwane.
Rozwiązanie
Pobierz najnowszą wersję narzędzi zestawu SDK z narzędzia Nuget.
Więcej informacji
Aby uzyskać więcej informacji na temat zmiany wymagania protokołu TLS 1.2, zobacz Microsoft Dynamics 365 Customer Engagement (online), aby wymagać protokołu TLS 1.2 na potrzeby łączności.