Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Ten artykuł zawiera rozwiązanie problemu, który powoduje wyświetlenie błędu Nie można utworzyć połączenia ze źródłem danych 'CRM', kiedy uruchamiasz raport Microsoft Dynamics CRM w Menedżerze raportów SRS lub na serwerze SRS.
Dotyczy: Microsoft Dynamics CRM 2011
Oryginalny numer KB: 2006869
Symptomy
Podczas uruchamiania raportu programu Microsoft Dynamics CRM w Menedżerze raportów usług SRS lub serwerze raportów usług SRS są wyświetlane następujące błędy:
Wystąpił błąd podczas przetwarzania raportu (rsProcessingAborted)
Nie można utworzyć połączenia ze źródłem danych "CRM". (rsBłądOtwieraniaPołączenia)
Identyfikator GUID powinien zawierać 32 cyfry z 4 kreskami (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).
Wystąpił błąd podczas przetwarzania raportu. (Przetwarzanie przerwane - rsProcessingAborted)
Nie można utworzyć połączenia ze źródłem danych "CRM". (rsBłądOtwieraniaPołączenia)
Aby uzyskać więcej informacji na temat tego błędu, przejdź do serwera raportów na lokalnym serwerze lub włącz wyświetlanie błędów zdalnych.
Przyczyna
Ten błąd występuje w programie Microsoft Dynamics CRM 2011, ponieważ rozszerzenia raportowania programu Microsoft Dynamics CRM wymagają wartości SystemUserId użytkownika jako nazwy logowania i wartości OrganizationId użytkownika jako hasła.
Gdy raport jest uruchamiany w programie Microsoft Dynamics CRM, te wartości są przekazywane automatycznie. Te wartości należy wprowadzić ręcznie, gdy raport jest uruchamiany bezpośrednio z usług SQL Server Reporting Services.
Rozwiązanie
Uzyskaj identyfikator SystemUserId i OrganizationId z bazy danych i ręcznie wprowadź wartości, wykonując następujące kroki:
- Połącz się z maszyną programu SQL Server zawierającą bazy danych programu Microsoft Dynamics CRM jako użytkownik, który ma uprawnienia administratora do programu SQL Server.
- Wybierz pozycję Start, wybierz pozycję Wszystkie programy, wybierz pozycję Microsoft SQL Server, a następnie wybierz pozycję SQL Server Management Studio.
- Wybierz pozycję Nowe zapytanie.
- Wybierz Plik, wybierz Nowy, a następnie wybierz Zapytanie aparatu bazy danych.
- Wybierz swoją organizację<>_MSCRM z listy rozwijanej.
- Wykonaj następujące zapytanie:
- Wybierz FullName, SystemUserId, OrganizationId
- Od filtrowanego użytkownika systemu
- Sortuj według pełnej nazwy
- Znajdź użytkownika, który uruchomi raport.
- Wprowadź wartość SystemUserId w polu Nazwa logowania w raporcie.
- Wprowadź wartość OrganizationId w polu hasło w raporcie.
- Uruchom raport.
Więcej informacji
Takie podejście powinno być używane tylko do rozwiązywania problemów z raportami programu Microsoft Dynamics CRM. Aby uruchamiać raporty programu Microsoft Dynamics CRM poza programem Microsoft Dynamics CRM, raporty powinny być publikowane do użytku zewnętrznego. Publikując raport do użytku zewnętrznego, połączysz się z danymi programu Microsoft Dynamics CRM przy użyciu ciągu połączenia programu SQL Server i nie zostanie wyświetlony monit o wprowadzenie poświadczeń.
Aby opublikować raporty do użytku zewnętrznego, wykonaj następujące kroki:
- Otwórz program Microsoft Dynamics CRM, a następnie wybierz pozycję Raporty.
- Wybierz raport, a następnie wybierz pozycję Edytuj raport.
- Wybierz menu Akcje, a następnie wybierz pozycję Publikuj raport do użytku zewnętrznego.
Spowoduje to utworzenie kopii raportu w katalogu głównym <folderu OrganizationName>_MSCRM w usługach SQL Server Reporting Services. Ta kopia raportu będzie używać źródła danych MSCRM_DataSource, które znajduje się w katalogu głównym folderu <OrganizationName>_MSCRM. To źródło danych używa programu Microsoft SQL Server jako typu połączenia i zabezpieczeń zintegrowanych z systemem Windows.