Udostępnij za pośrednictwem


Podczas uruchamiania programu Outlook wystąpił błąd ładowania funkcjonalności programu Microsoft Dynamics CRM.

Ten artykuł zawiera rozwiązania problemów, które mogą wystąpić podczas uruchamiania klienta programu Microsoft Dynamics CRM dla programu Outlook.

Dotyczy: Klient aplikacji Microsoft CRM dla programu Microsoft Office Outlook
Oryginalny numer KB: 911384

Symptomy

Objawy 1

Po otwarciu klienta programu Microsoft Dynamics CRM dla programu Microsoft Office Outlook zostanie wyświetlony następujący komunikat o błędzie:

Wystąpił błąd podczas ładowania funkcji programu Microsoft CRM. Spróbuj ponownie uruchomić program Outlook.

W dzienniku zdarzeń rejestrowane są komunikaty o błędach podobne do następujących.

Komunikat o błędzie 1

Nie można odnaleźć opisu identyfikatora zdarzenia ( 2 ) w źródle ( Microsoft CRM). Lokalny komputer może nie mieć wymaganych informacji z rejestru ani plików DLL potrzebnych do wyświetlania komunikatów z komputera zdalnego. Aby pobrać ten opis, może być możliwe użycie flagi /AUXSOURCE=; Aby uzyskać szczegółowe informacje, zobacz Pomoc i obsługa techniczna.

Poniższe informacje są częścią zdarzenia. Raport o błędach platformy MSCRM:

Błąd: Wyjątek od HRESULT: 0x80040220. Komunikat o błędzie: Wyjątek od HRESULT: 0x80040220. Szczegóły błędu: Szczegóły dotyczące tego błędu nie zostały podane przez platformę. Plik źródłowy: niedostępny numer wiersza: niedostępne informacje o śledzeniu stosu: w System.Web.UI.Page.HandleError(Exception e) w System.Web.UI.Page.ProcessRequestMain() w System.Web.UI.Page.ProcessRequest() w System.Web.UI.Page.ProcessRequest(HttpContext context) w System.Web.CallHandlerExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute() w System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously).

Komunikat o błędzie 2

Nie można odnaleźć opisu identyfikatora zdarzenia (16930 ) w źródle ( MSCRMAddin). Lokalny komputer może nie mieć wymaganych informacji z rejestru ani plików DLL potrzebnych do wyświetlania komunikatów z komputera zdalnego. Aby pobrać ten opis, może być możliwe użycie flagi /AUXSOURCE=; Aby uzyskać szczegółowe informacje, zobacz Pomoc i obsługa techniczna. Następujące informacje są częścią zdarzenia: 80004005, , CAddin::HrActivateAddin, 472.

Komunikat o błędzie 3

Nie można odnaleźć opisu identyfikatora zdarzenia (5944 ) w źródle ( MSCRMAddin). Lokalny komputer może nie mieć wymaganych informacji z rejestru ani plików DLL potrzebnych do wyświetlania komunikatów z komputera zdalnego. Aby pobrać ten opis, może być możliwe użycie flagi /AUXSOURCE=; Aby uzyskać szczegółowe informacje, zobacz Pomoc i obsługa techniczna. Następujące informacje są częścią zdarzenia: 80004005, , CAddin::HrInitializeUI, 137.

Objawy 2

Jeśli używasz systemu Windows Vista z programem Microsoft Dynamics CRM dla programu Outlook i po włączeniu śledzenia platformy, zostanie wyświetlony komunikat o błędzie podobny do następującego:

Konfiguracja klienta: [Błąd] Klucze rejestru COM wydają się być uszkodzone. Uruchom ponownie Kreatora konfiguracji programu CRM lub skontaktuj się z administratorem programu Microsoft Dynamics CRM. >--- System.TypeLoadException: Pobieranie fabryki klasy COM dla składnika o identyfikatorze CLSID {<ID>} nie powiodło się z powodu następującego błędu: 80131522. o
System.RuntimeTypeHandle.CreateInstance(RuntimeType type, bool publicOnly, bool noCheck, bool canBeCached, RuntimeMethodHandle& ctor, bool bNeedSecurityCheck) pod adresem
System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache) w: System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache) pod adresem
System.Activator.CreateInstance(Type type, Boolean nonPublic) w
Microsoft.Crm.Outlook.Diagnostics.ComponentObjectModelDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) --- Koniec śledzenia stosu wyjątku wewnętrznego ---
Microsoft.Crm.Outlook.Diagnostics.ComponentObjectModelDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) w Microsoft.Crm.Outlook.Diagnostics.DiagnosticCheck.DeepExecute(BackgroundWorker backgroundWorker)

Objawy 3

Podczas próby uruchomienia klienta programu Microsoft Dynamics CRM dla programu Outlook nie można wyświetlić struktury folderów programu Microsoft Dynamics CRM. Ponadto wyświetlany zostanie następujący komunikat o błędzie:

Wystąpił błąd podczas ładowania funkcji programu Microsoft CRM. Spróbuj ponownie uruchomić program Outlook.

W dzienniku zdarzeń są rejestrowane następujące komunikaty o błędach:

Typ zdarzenia: Błąd Źródło zdarzenia: MSCRMAddin Kategoria zdarzenia: Brak Identyfikator zdarzenia: 16930 Data: Data Godzina: Godzina Użytkownik: N/A Komputer: ComputerName Opis: Inicjowanie interfejsu użytkownika programu Microsoft CRM nie powiodło się. Spróbuj ponownie uruchomić program Microsoft Outlook. HR=0x80004005. Kontekst=. Function=CAddin::HrActivateAddin. Linia=521. Ponadto w pliku dziennika śledzenia OUTLOOK-YYDDMM.log jest wyświetlany następujący komunikat o błędzie: [Data i godzina] Proces: OUTLOOK |Thread:0832 |Kategoria: Unmanaged.Platform |Użytkownik: PlatformUser |Poziom: Błąd | HrGetXmlDOM Plik: c:\bt\643\src\application\outlook\v3caddin\xmlutil.cpp Linia: 179 >hr = 0x80004005

Uwaga

W tym komunikacie o błędzie symbol zastępczy "Data i godzina" reprezentuje datę i czas rzeczywisty. Na przykład rzeczywista data i rzeczywista godzina to "2007-10-19 17:53:26.138".

Objawy 4

Po uruchomieniu klienta programu Microsoft Dynamics CRM dla programu Outlook zostanie wyświetlony następujący komunikat o błędzie:

Wystąpił błąd podczas ładowania funkcji programu Microsoft CRM. Spróbuj ponownie uruchomić program Outlook. Ponadto zdarzenie błędu 80072f19 jest przywoływane w dzienniku aplikacji: Zdarzenie: 16941 Wystąpił problem podczas inicjowania paska postępu. Uruchom ponownie program Microsoft CRM i spróbuj ponownie. HR=0x80072f19. Kontekst=. Function=CAddin::HrActivateAddin. Linia=322.

Objawy 5

Podczas próby uruchomienia programu Microsoft Office Outlook na komputerze z zainstalowanym klientem programu Microsoft Dynamics CRM dla programu Outlook zostanie wyświetlony następujący komunikat o błędzie:

Wystąpił błąd podczas ładowania funkcji programu Microsoft Dynamics CRM.

Spróbuj ponownie uruchomić program Microsoft Outlook.

Skontaktuj się z administratorem systemu, jeśli błędy będą się powtarzać.

Ponadto w dzienniku zdarzeń aplikacji jest rejestrowany następujący komunikat o błędzie:

Typ zdarzenia: Błąd
Źródło zdarzenia: MSCRMAddin
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 16931
Opis rozwiązania:

Wystąpił problem przy inicjowaniu międzyoperacyjności Microsoft CRM COM. Uruchom ponownie program Microsoft CRM i spróbuj ponownie. HR=0x80131700. Kontekst=. Function=CAddin::HrActivateAddin. Linia=274.

Typ zdarzenia: Błąd
Źródło zdarzenia: MSCRMAddin
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 5903
Opis rozwiązania:

Nie można poprawnie zainicjować dodatku programu Microsoft CRM Outlook. Uruchom ponownie program Microsoft Outlook i spróbuj ponownie. HR=0x80070057. Kontekst=. Function=CAddin::OnConnection. Line=196.

Przyczyna

Przyczyna 1

Ten problem występuje, ponieważ rola przypisana do konta użytkownika nie ma uprawnień do odczytu jednostki Zapisany widok w programie Microsoft Dynamics CRM. Zobacz Rozwiązanie 1.

Przyczyna 2

Konfiguracja Wyłączenia Strony Głównej Folderu jest włączona za pomocą Zasad Grupy. Konfiguracja Wyłącz stronę główną folderu to konfiguracja szablonu administracyjnego pakietu Microsoft Office 2003 (OUTLK11.adm). Jeśli to ustawienie jest włączone, pakiet Office 2003 nie może załadować struktury folderów programu Microsoft Dynamics CRM. Zobacz Rozwiązanie 2.

Przyczyna 3

Ten problem występuje, jeśli w IIS brakuje mapowań dla rozszerzeń .srf, które wskazują na plik CRMisapi.dll. Zobacz Rozwiązanie 3.

Przyczyna 4

Ten problem występuje, ponieważ włączono sprawdzanie odwołania certyfikatu serwera. Zobacz Rozwiązanie 4.

Przyczyna 5

Ten problem występuje, ponieważ plik Outlook.exe.config istnieje w folderze instalacyjnym pakietu Microsoft Office. Ten plik jest używany w wystąpieniach rozwiązywania problemów z klientem programu Microsoft Outlook CRM dla programu Outlook, aby program Outlook mógł używać określonej wersji programu Microsoft .NET Framework. Zobacz Rozwiązanie 5.

Rozwiązanie

Rozwiązanie 1

Aby poprawnie uruchomić klienta programu Microsoft Dynamics CRM dla programu Outlook, rola przypisana do konta użytkownika musi mieć dostęp do odczytu do jednostki Zapisany widok. Aby zmienić dostęp użytkownika, wykonaj następujące kroki:

  1. Otwórz program Microsoft Dynamics CRM.
  2. Wybierz Ustawienia, wybierz Ustawienia, wybierz Ustawienia jednostki biznesowej, wybierz Użytkownicy, a następnie kliknij dwukrotnie użytkownika, aby go otworzyć.
  3. Wybierz Role, kliknij dwukrotnie rolę, aby ją otworzyć, wybierz kartę Rekordy podstawowe, a następnie wybierz Odczyt dostępu dla jednostki Zapisany widok.

Rozwiązanie 2

Aby rozwiązać ten problem, zmień ustawienie konfiguracji Wyłącz stronę główną folderu na stan wyłączony . W tym celu wykonaj następujące kroki dla programu Outlook 2003:

  1. Aby edytować zasady grupy zawierające szablon administracyjny pakietu Office 2003, otwórz Edytor obiektów zasad grupy.
  2. Rozwiń węzeł Konfiguracja użytkownika, rozwiń węzeł Zasady, rozwiń węzeł Szablony administracyjne, a następnie rozwiń węzeł Microsoft Office Outlook 2003.
  3. Wybierz Strony główne folderów dla specjalnych folderów programu Outlook, a następnie kliknij dwukrotnie Wyłącz strony główne folderów.
  4. Na stronie Właściwości wyłączenia stron głównych folderu zaznacz pole wyboru Wyłączone, a następnie wybierz OK.
  5. Zamknij Edytor obiektów zasad grup.
  6. Uruchom ponownie komputer kliencki, którego dotyczy problem.

Wykonaj następujące kroki dla programu Outlook 2007:

  1. Aby edytować zasady grupy zawierające szablon administracyjny pakietu Office 2007, otwórz Edytor obiektów zasad grupy.
  2. Rozwiń Konfiguracja użytkownika, rozwiń Zasady, rozwiń Szablony administracyjne, a następnie rozwiń Microsoft Office Outlook 2007.

    [UWAGA] Folder Microsoft Office Outlook 2007 może znajdować się w obszarze Klasyczne szablony administracyjne (ADM).

  3. Wybierz Strony główne folderów dla specjalnych folderów programu Outlook, a następnie kliknij dwukrotnie Nie zezwalaj na ustawienie adresu URL strony głównej w Właściwościach folderu.
  4. Na stronie Nie zezwalaj na ustawianie adresu URL strony głównej na stronie Właściwości folderu zaznacz pole wyboru Wyłączone, a następnie wybierz przycisk OK.
  5. Zamknij Edytor obiektów zasad grup.
  6. Uruchom ponownie komputer kliencki, którego dotyczy problem.

Rozwiązanie 3

Aby rozwiązać ten problem, dodaj mapowanie pliku .srf do witryny internetowej Microsoft Dynamics CRM. W tym celu wykonaj następujące kroki:

  1. Rozwiń witrynę Microsoft Dynamics CRM w usługach IIS.
  2. Kliknij prawym przyciskiem myszy katalog wirtualny aplikacji MSCRMServices , a następnie wybierz pozycję Właściwości.
  3. Na karcie Katalog wirtualny wybierz pozycję Konfiguracja.
  4. W sekcji Rozszerzenia aplikacji wybierz pozycję Dodaj.
  5. Znajdź plik CRMIsapi.dll, a następnie umieść ścieżkę w cudzysłowie w następujący sposób:
    C:\Program Files\Microsoft CRM\Server\bin\CrmIsapi.dll
  6. W polu Rozszerzenie wprowadź .srf.
  7. W polu Limit do wpisz GET, POST, HEAD.
  8. Zaznacz pole wyboru Silnik skryptów oraz Sprawdź, czy plik istnieje, a następnie wybierz OK.
  9. Zresetuj usługi IIS. W tym celu wybierz pozycję Start, wybierz pozycję Uruchom, wpisz iisreset w polu Otwórz, a następnie wybierz przycisk OK.

Rezolucja 4

Aby rozwiązać ten problem, wykonaj następujące kroki:

  1. W programie Internet Explorer wybierz menu Narzędzia , a następnie wybierz pozycję Opcje internetowe.
  2. Wybierz kartę Zaawansowane , a następnie wyczyść pole wyboru Sprawdź odwołanie certyfikatów serwera (wymaga ponownego uruchomienia).
  3. Uruchom ponownie program Outlook.

Rozwiązanie 5

Aby rozwiązać ten problem, usuń lub zmień nazwę pliku Outlook.exe.config, a następnie uruchom ponownie program Outlook.