Udostępnij za pośrednictwem


Instalacja Asystenta logowania Windows Live ID nie powiodła się, kod błędu "1603", podczas instalowania klienta programu Microsoft Dynamics CRM 2011 dla programu Outlook.

Ten artykuł zawiera rozwiązanie błędu Instalacja Asystenta logowania Windows Live ID nie powiodła się, który występuje podczas instalacji klienta programu Microsoft Dynamics CRM 2011 dla programu Outlook.

Dotyczy: Microsoft Dynamics CRM Online
Oryginalny numer KB: 2549386

Objawy

Podczas instalowania wymagań wstępnych klienta programu Microsoft Dynamics CRM 2011 dla programu Outlook instalacja Asystenta logowania w usłudze Windows Live ID kończy się niepowodzeniem, powodując przedwczesne zakończenie instalacji klienta programu Microsoft Dynamics CRM 2011 dla programu Outlook. Badanie pliku crm50setup.log zgłosi następujący komunikat o błędzie:

Instalacja Asystenta logowania w usłudze Windows Live ID nie powiodła się. Kod zakończenia: 1603. Wynik: błąd krytyczny podczas instalacji.

Przyczyna

W niektórych systemach instalacja Asystenta logowania usługi Windows Live ID zakończy się niepowodzeniem, jeśli nie określono dodatkowego parametru instalacji. Domyślnie klient programu Microsoft Dynamics CRM 2011 dla programu Outlook nie określa tego dodatkowego parametru.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące kroki:

  1. Pobierz Asystenta logowania usługi Windows Live ID i zapisz go w folderze na lokalnym dysku twardym.
  2. Przejdź do Start>Programy>Akcesoria>Wiersz polecenia.
  3. Wpisz cd c:\<folder name>. <folder name> to lokalizacja, w której pobrano Asystenta.
  4. Wpisz Msiexec /i wllogin_32.msi /l*v C:\setupLogs.log NOMU=1.
  5. Po zakończeniu instalacji Asystenta logowania systemu Windows Live uruchom ponownie instalację klienta programu Microsoft Dynamics CRM 2011 dla programu Outlook.