Udostępnij za pośrednictwem


Zalogowany użytkownik nie ma odpowiednich uprawnień zabezpieczeń po uaktualnieniu do programu Microsoft Dynamics CRM 2011.

Ten artykuł zawiera rozwiązanie problemu, którego nie można uaktualnić do programu Microsoft Dynamics CRM 2011 z powodu błędu (zalogowany użytkownik nie ma odpowiednich uprawnień zabezpieczeń do wyświetlania tych rekordów lub wykonania konkretnej akcji).

Dotyczy: Microsoft Dynamics CRM 2011
Oryginalny numer KB: 953962

Symptomy

Po uaktualnieniu do programu Microsoft Dynamics CRM 2011 użytkownik może napotkać poniższy błąd podczas próby wykonania akcji w programie Microsoft Dynamics CRM:

Zalogowany użytkownik nie ma odpowiednich uprawnień zabezpieczeń do wyświetlania tych rekordów ani wykonywania konkretnej akcji.

Jeśli śledzenie platformy Microsoft Dynamics CRM jest włączone, ślad platformy zawiera następujące informacje o błędzie:

Raport o błędach MSCRM:

--------------------------------------------------------------------------------------------------------
Błąd: Serwer nie mógł przetworzyć żądania.
Numer błędu: 0x80040220
Komunikat o błędzie: SecLib::CrmCheckPrivilege nie powiodło się. Zwrócono hr = -2147220960 dla UserId: <ID> i PrivilegeId: <ID>

Uwaga

W tym przykładzie informacji, wartość UserId i wartość PrivilegeId są symbolami zastępczymi wartości rzeczywistych.

Przyczyna

Po uaktualnieniu do programu Microsoft Dynamics CRM 2011 niestandardowe role zabezpieczeń nie są automatycznie przyznawane uprawnienia do wszystkich nowych funkcji. Tylko role gotowe do użycia zostaną przyznane uprawnienia domyślne.

Ten problem może również wystąpić, jeśli rola użytkownika nie ma uprawnień wymaganych do wykonania akcji. Taka sytuacja może wystąpić, jeśli spełniony jest jeden z następujących warunków:

  • Rola została utworzona od podstaw.
  • Rola została skopiowana ze standardowej roli. Następnie rola została szeroko edytowana.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące kroki.

Uwaga

Te kroki wymagają informacji ze śledzenia na platformie Microsoft Dynamics CRM.

  1. W informacjach o błędzie wyświetlanych w śladzie platformy Microsoft Dynamics CRM znajdź wartość PrivilegeId.

  2. Ustal brakujące uprawnienia, uruchamiając zapytanie SQL używające wartości PrivilegeId. Na przykład uruchom zapytanie SQL podobne do następującego w bazie danych OrganizationName_MSCRM.

    select Name, * from PrivilegeBase where PrivilegeId = 'a8ecac53-09e8-4a13-b598-8d8c87bc3d33'
    
  3. Aby przyznać użytkownikowi brakujące uprawnienia, wykonaj następujące kroki:

    1. Uruchom program Microsoft Dynamics CRM 2011.
    2. Wybierz pozycję Ustawienia, wybierz pozycję Administracja w obszarze Ustawienia, a następnie wybierz pozycję Role zabezpieczeń.
    3. Kliknij dwukrotnie rolę przypisaną do użytkownika.
    4. Przyznaj brakujący przywilej roli użytkownika. Aby na przykład przyznać uprawnienie prvReadLead do roli użytkownika, wybierz kartę Rekordy Podstawowe, a następnie w wierszu Lead wybierz odpowiednie uprawnienie do odczytu.
    5. Wybierz pozycję Zapisz i zamknij.