Błąd "Crystal Print Engine Error 536" lub "System Message 7014" podczas próby wydrukowania lub wydrukowania podglądu raportu niestandardowego w usłudze Microsoft Dynamics SL
Ten artykuł zawiera wiele rozwiązań problemu, w którym są wyświetlane dwa komunikaty o błędach podczas drukowania lub drukowania podglądu raportu niestandardowego.
Dotyczy: Microsoft Dynamics SL
Oryginalny numer KB: 897023
Symptomy
Po wydrukowaniu raportu niestandardowego lub wyświetleniu podglądu raportu niestandardowego przed wydrukowaniem go w usłudze Microsoft Dynamics SL są wyświetlane następujące komunikaty o błędach:
Błąd aparatu crystal print: błąd 536 w pliku. Nie można nawiązać połączenia: nieprawidłowe parametry logowania.
Komunikat systemowy 7014: Wykonanie raportu nie powiodło się z powodu błędu 536.
Przyczyna
Ten problem występuje z co najmniej jednej z następujących przyczyn.
Przyczyna 1
Parametr Zaufane połączenie w pliku raportu jest ustawiony na 1. Zobacz Rozwiązanie 1.
Przyczyna 2
Połączenie Open Database Connectivity (ODBC) na stacji roboczej jest uszkodzone. Zobacz Rozwiązanie 2.
Przyczyna 3
Raport wskazuje dwie różne bazy danych. Zobacz Rozwiązanie 3.
Przyczyna 4
Konto logowania E7F575915A2E4897A517779C0DD7CE w SQL Server 2005 r. lub w SQL Server 2008 r. jest wyłączone lub ma nieprawidłowe hasło. Zobacz Rozwiązanie 4.
Rozwiązanie
Aby rozwiązać ten problem, użyj odpowiedniego rozwiązania.
Uchwała 1
Aby rozwiązać ten problem, ustaw parametr Zaufane połączenie w pliku raportu na wartość 0 (zero). Aby tego dokonać, wykonaj następujące kroki:
Uruchom Crystal Reports 10 dla Salomona.
Wybierz pozycję Otwórz, wybierz raport niestandardowy, a następnie wybierz pozycję Otwórz.
W menu Baza danych wybierz pozycję Ustaw lokalizację źródła danych.
W oknie dialogowym Ustawianie lokalizacji źródła danych rozwiń węzeł Bieżące źródło danych: właściwości.
W obszarze Bieżące źródło danych: właściwości znajdź parametr Zaufane połączenie: 1 .
Uwaga
Jeśli na liście nie ma parametru Zaufane połączenie , opcja Zaufane połączenie nie została wybrana podczas tworzenia raportu i nie jest to przyczyna błędu.
Kliknij prawym przyciskiem myszy pozycję Zaufane połączenie: 1, a następnie wybierz pozycję Edytuj.
Wpisz 0.
Wybierz pozycję Zamknij.
Wybierz Zapisz.
Uchwała 2
Aby rozwiązać ten problem, usuń połączenia MICROSOFT Dynamics SL ODBC. Następnie pozwól usłudze Microsoft Dynamics SL na ponowne utworzenie połączeń. Aby tego dokonać, wykonaj następujące kroki:
- Wybierz pozycję Start, wybierz pozycję Panel sterowania, wybierz pozycję Narzędzia administracyjne, a następnie wybierz pozycję Źródła danych (ODBC).
- Na karcie User DSN (Nazwa DSN użytkownika ) usuń wszystkie elementy wskazujące bazy danych aplikacji Microsoft Dynamics SL.
- Na karcie System DSN usuń wszystkie elementy wskazujące bazy danych aplikacji Microsoft Dynamics SL.
- Uruchom ponownie raport w usłudze Microsoft Dynamics SL. Połączenia ODBC są automatycznie ponownie tworzone po uruchomieniu raportu w usłudze Microsoft Dynamics SL.
Uchwała 3
Aby rozwiązać ten problem, zresetuj źródło danych w aplikacji Crystal Reports. Aby tego dokonać, wykonaj następujące kroki:
- Uruchom Crystal Reports 10 dla Salomona.
- Wybierz pozycję Otwórz, wybierz raport niestandardowy, a następnie wybierz pozycję Otwórz.
- W menu Baza danych wybierz pozycję Ustaw lokalizację źródła danych.
- W polu Zamień na rozwiń węzeł Utwórz nowe połączenie, a następnie rozwiń węzeł ODBC (RDO).
- Wybierz bazę danych Microsoft Dynamics SL, a następnie wybierz pozycję Dalej.
- Wprowadź informacje logowania. Nie zaznaczaj pola wyboru Zaufane połączenie .
- Wybierz Zakończ.
- Wybierz bazę danych w polu Zastąp element . Następnie wybierz bazę danych w polu Bieżące źródło danych .
- Wybierz pozycję Aktualizuj.
- Jeśli w polu Bieżące źródło danych znajduje się wiele baz danych, powtórz kroki 8 i 9 dla każdej bazy danych.
- Wybierz pozycję Zapisz, a następnie zamknij pozycję Crystal Reports.
Uchwała 4
Aby rozwiązać ten problem, włącz konto logowania E7F575915A2E4897A517779C0DD7CE w SQL Server 2005 r. lub w SQL Server 2008 r., a następnie uruchom scenariusz aktualizacji Synchronizuj całą własność & Zabezpieczenia na ekranie Konserwacja bazy danych (98.290.00) w usłudze Microsoft Dynamics SL. Aby tego dokonać, wykonaj następujące kroki:
- Uruchom SQL Server Management Studio, a następnie połącz się z serwerem hostującym bazy danych Microsoft Dynamics SL.
- W okienku Eksplorator obiektów rozwiń węzeł Zabezpieczenia, a następnie rozwiń węzeł Identyfikatory logowania.
- W obszarze Logowania kliknij prawym przyciskiem myszy pozycję E7F575915A2E4897A517779C0DD7CE, a następnie wybierz pozycję Właściwości.
- W okienku Wybierz stronę wybierz pozycję Stan, a następnie wybierz pozycję Włączone w obszarze Logowanie.
- Wybierz przycisk OK, a następnie zamknij SQL Server Management Studio.
- W Panel sterowania wybierz pozycję Narzędzia administracyjne, a następnie wybierz pozycję Konserwacja bazy danych Microsoft Dynamics SL.
- Połącz się z wystąpieniem SQL Server hostującym bazy danych Microsoft Dynamics SL.
- Wybierz kartę Aktualizuj bazę danych .
- Na liście Scenariusze aktualizacji wybierz pozycję Synchronizuj całą własność & Zabezpieczenia, a następnie wybierz pozycję Aktualizuj bazę danych.
- W dolnej części ekranu Konserwacja bazy danych (98.290.00) upewnij się, że pasek postępu został ukończony, a następnie wybierz pozycję Zamknij.