Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Problem
Rozważmy następujący scenariusz: Użytkownik nie może zalogować się do usługi w chmurze firmy Microsoft, takiej jak Microsoft 365, Microsoft Azure lub Microsoft Intune, przy użyciu identyfikatora użytkownika będącego członkiem domeny usługi w chmurze, która była wcześniej skonfigurowana do logowania jednokrotnego. W tym scenariuszu, gdy administrator usługi w chmurze próbuje zresetować hasło użytkownika przy użyciu portalu usługi w chmurze lub modułu usługi Azure Active Directory dla programu Windows PowerShell, administrator otrzymuje następujący komunikat o błędzie:
Nie można zresetować hasła tego użytkownika. Spróbuj ponownie później.
Przyczyna
Ten problem występuje, jeśli użytkownik jest członkiem domeny usługi w chmurze, która miała wcześniej włączone logowanie jednokrotne (SSO), i jeśli identyfikator użytkownika nie został przekonwertowany na uwierzytelnianie standardowe.
Na przykład ten problem może wystąpić, jeśli użyto następującego polecenia cmdlet programu Windows PowerShell:
convert-MSOLDomainToStandard –skipuserconversion:$true
Uwaga / Notatka
Moduły Azure AD i MSOnline PowerShell będą wycofane z dniem 30 marca 2024 r. Aby dowiedzieć się więcej, przeczytaj aktualizację na temat wycofania. Po tej dacie obsługa tych modułów jest ograniczona do pomocy dotyczącej migracji do zestawu MICROSOFT Graph PowerShell SDK i poprawek zabezpieczeń. Przestarzałe moduły będą nadal działać do 30 marca 2025 r.
Zalecamy migrację do programu Microsoft Graph PowerShell w celu interakcji z identyfikatorem Entra firmy Microsoft (dawniej Azure AD). W przypadku typowych pytań dotyczących migracji zapoznaj się z często zadawanymi pytaniami dotyczącymi migracji. Uwaga: Wersje 1.0.x usługi MSOnline mogą napotkać zakłócenia po 30 czerwca 2024 r.
Rozwiązanie
Aby rozwiązać ten problem, przekonwertuj identyfikator użytkownika na standardowy typ (inny niż federacyjny). Aby to zrobić, wykonaj następujące kroki:
- W tej samej konsoli programu Windows PowerShell, która była używana do zweryfikowania problemu, wpisz następujące polecenie cmdlet, a następnie naciśnij Enter:
Convert-MsolFederatedUser -userprincipalname < user ID >
Uwaga / Notatka
W tym poleceniu cmdlet symbol zastępczy <identyfikator> użytkownika reprezentuje identyfikator użytkownika.
- Nadaj użytkownikowi hasło tymczasowe. Następnym razem, gdy użytkownik zaloguje się do usługi w chmurze, musi zmienić swoje tymczasowe hasło, zanim będzie mógł uzyskać dostęp do zasobów usługi w chmurze.
Więcej informacji
Uwaga / Notatka
Polecenia cmdlet programu Windows PowerShell w tym artykule wymagają modułu Azure Active Directory dla programu Windows PowerShell.
Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community lub witryny forów Microsoft Entra .