Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Uwaga
Silverlight wycofał się i jest oficjalnie poza wsparciem. Aby uzyskać więcej informacji, zobacz Koniec wsparcia dla programu Silverlight.
Symptomy
Podczas próby uzyskania dostępu do witryny sieci Web wymagającej wyświetlania zawartości przez program Silverlight zostanie wyświetlony komunikat o błędzie informujący o konieczności zainstalowania programu Silverlight.
Przyczyna
Takie zachowanie może wystąpić z kilku powodów:
System ma starszą wersję wtyczki i nie spełnia wymagań dotyczących wtyczki używanej przez stronę.
Nie masz zainstalowanej wtyczki.
Przeglądarka jest ustawiona na "Uruchomienie przy użyciu Rosetta", co spowoduje, że komputer zostanie niepoprawnie zidentyfikowany jako Mac z procesorem opartym na PowerPC.
Rozwiązanie
Przed ustaleniem, jak rozwiązać ten problem, należy ocenić bieżące środowisko, w którym działa oprogramowanie. W tym celu wykonaj następujące kroki:
W menu firmy Apple wybierz pozycję Informacje o tym komputerze Mac.
Zwróć uwagę na typ procesora, szybkość, pamięć RAM i informacje o systemie operacyjnym, ponieważ niektóre witryny sieci Web mają określone wymagania dotyczące wyświetlania zawartości.
Zamknięcie okna.
Zamknij wszystkie otwarte okna przeglądarki.
Kliknij dwukrotnie ikonę dysku twardego na pulpicie.
Kliknij dwukrotnie folder Biblioteka.
Otwórz folder wtyczki internetowe.
Czy istnieje plik o nazwie Silverlight.plugin? Jeśli ten plik istnieje, wtyczka jest zainstalowana. Aby określić wersję, kliknij, aby wybrać plik. Następnie wybierz pozycję Pobierz informacje w menu Plik . Zwróć uwagę na wyświetlany numer wersji.
Jeśli wyświetlany numer wersji jest 1.0.xxx, a typ procesora to PowerPC, masz zainstalowaną poprawną wersję wtyczki.
Jeśli masz procesor Intel, obsługiwane są wszystkie wersje programu Silverlight. Zalecamy jednak uruchomienie najnowszej wersji, dzięki czemu można uzyskiwać dostęp do witryn sieci Web korzystających z najnowszych funkcji i korzystać z najnowszych ulepszeń produktów.
Teraz możemy rozwiązać poszczególne przyczyny i rozwiązania.
System ma starszą wersję wtyczki i nie spełnia wymagań witryny sieci Web
Najczęstszą przyczyną tego problemu jest to, że witryna sieci Web używa programu Silverlight 3 dla jej zawartości. Jeśli strona wymaga wersji 3, rozpoznaje, czy Twój system spełnia wymagania. Jeśli system tego nie robi, zostanie wyświetlony monit o uaktualnienie. Zostanie wyświetlona witryna programu Silverlight. Jeśli używasz mikroprocesora PowerPC, witryna rozpoznaje to i umożliwia zainstalowanie tylko wersji 1. (Ta sytuacja musiałaby zostać rozwiązana przez zespół pomocy technicznej witryny sieci Web, ponieważ decyzja o tym, jakiej wersji programu Silverlight używać, jest podjęta przez projektantów witryn sieci Web).
Nie masz zainstalowanej wtyczki
Jeśli program Silverlight nie został jeszcze zainstalowany, wykonaj następujące kroki, aby zainstalować wtyczkę:
Uruchom przeglądarkę sieci Web, a następnie odwiedź następującą witrynę sieci Web:
Znajdź obszar "Zainstaluj program Silverlight" w prawym dolnym rogu okna.
Jeśli używasz procesora Intel, kliknij pozycję Środowisko uruchomieniowe dla komputerów Mac obok pozycji "Silverlight 3".
W przeciwnym razie wybierz pozycję Środowisko uruchomieniowe dla komputerów Mac PowerPC obok pozycji "Silverlight 1.0".
Po zakończeniu pobierania instalacja powinna zostać uruchomiona automatycznie. Postępuj zgodnie z krokami kreatora instalacji.
Po zakończeniu instalacji powinien zostać wyświetlony monit o zamknięcie przeglądarki. Zamknij wszystkie okna przeglądarki, a następnie uruchom ponownie przeglądarkę. Przeglądarka powinna rozpoznać nową wtyczkę.
Przeglądarka jest ustawiona na "Uruchom za pomocą Rosetty", co spowoduje, że komputer zostanie niepoprawnie zidentyfikowany jako Mac oparty na technologii PowerPC.
Jeśli przeglądarka jest ustawiona do uruchamiania w silniku Rosetta, niepoprawnie zidentyfikuje komputer jako Mac oparty na platformie PowerPC lub strona internetowa nie rozpozna, że zainstalowano odpowiednią wtyczkę.
Jeśli odpowiednia wtyczka jest zainstalowana zgodnie z opisem w poprzedniej sekcji, wykonaj następujące kroki:
Kliknij dwukrotnie ikonę dysku twardego na pulpicie.
Wybierz folder Aplikacje.
Znajdź ikonę używanej przeglądarki. Przytrzymaj wciśnięcie CONTROL po kliknięciu tej ikony.
Wybierz pozycję Pobierz informacje.
Znajdź opcję Uruchom przy użyciu platformy Rosetta i upewnij się, że to pole wyboru nie jest zaznaczone. Jeśli jest zaznaczona, kliknij, aby wyczyścić pole wyboru. Zamknięcie okna.
W menu firmy Apple wybierz pozycję Uruchom ponownie.
Po ponownym uruchomieniu komputera spróbuj ponownie uzyskać dostęp do witryny sieci Web, która wygenerowała komunikat o błędzie.
Uwaga
Jeśli nie zainstalowano odpowiedniej wersji wtyczki, upewnij się, że pole wyboru Uruchom przy użyciu rosetta nie jest zaznaczone, a następnie wykonaj kroki opisane w poprzedniej sekcji, aby zainstalować wtyczkę.