Błąd AADSTS50003 — nie skonfigurowano klucza podpisywania
W tym artykule opisano problem, w którym jest wyświetlany komunikat o błędzie "Błąd AADSTS50003 — nie skonfigurowano klucza podpisywania". Podczas próby zalogowania się do aplikacji skonfigurowanej do logowania jednokrotnego (SSO) opartej na protokole SAML, która została zintegrowana z Tożsamość Microsoft Entra.
Symptomy
Podczas próby zalogowania się do aplikacji, która została skonfigurowana do używania Tożsamość Microsoft Entra do zarządzania tożsamościami przy użyciu logowania jednokrotnego opartego na protokole SAML, występuje błądAADSTS50003
.
Przyczyna
Obiekt aplikacji jest uszkodzony i Tożsamość Microsoft Entra nie rozpoznaje certyfikatu skonfigurowanego dla aplikacji.
Rozwiązanie
Aby usunąć i utworzyć nowy certyfikat, wykonaj poniższe kroki:
- Na ekranie konfiguracji logowania jednokrotnego opartego na protokole SAML wybierz pozycję Utwórz nowy certyfikat w sekcji Certyfikat podpisywania SAML .
- Wybierz pozycję Data wygaśnięcia, a następnie kliknij przycisk Zapisz.
- Zaznacz opcję Uaktywnij nowy certyfikat , aby zastąpić aktywny certyfikat. Następnie kliknij przycisk Zapisz w górnej części okienka i zaakceptuj, aby aktywować certyfikat przerzucania.
- W sekcji Certyfikat podpisywania SAML kliknij przycisk usuń , aby usunąć nieużywany certyfikat.
Więcej informacji
Aby uzyskać pełną listę kodów błędów uwierzytelniania i autoryzacji usługi Active Directory, zobacz Microsoft Entra kody błędów uwierzytelniania i autoryzacji
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii platformy Azure.