Błąd AADSTS50011 z uwierzytelnianiem SAML — adres URL odpowiedzi określony w żądaniu jest niezgodny

Ten artykuł zawiera rozwiązanie błędu AADSTS50011 występującego podczas uwierzytelniania federacyjnego przy użyciu Tożsamość Microsoft Entra.

Symptomy

Podczas próby zalogowania się do aplikacji skonfigurowanej do używania Tożsamość Microsoft Entra do zarządzania tożsamościami przy użyciu logowania jednokrotnego opartego na protokole SAML występuje błądAADSTS50011.

Błąd AADSTS50011 — adres URL odpowiedzi nie jest zgodny z adresami URL odpowiedzi skonfigurowanymi dla identyfikatora GUID> aplikacji<. Upewnij się, że adres URL odpowiedzi wysłany w żądaniu jest zgodny z adresem dodanym do aplikacji w Azure Portal. Przejdź do obszaru, aby https://aka.ms/urlMismatchError dowiedzieć się więcej o tym, jak rozwiązać ten problem." podczas próby zalogowania się do aplikacji ze skonfigurowaną usługą Single Sign-On (SSO) opartą na protokole SAML, która została zintegrowana z Tożsamość Microsoft Entra.

Przyczyna

Wartość AssertionConsumerServiceURL w żądaniu SAML nie jest zgodna z wartością adresu URL odpowiedzi lub wzorcem skonfigurowanym w Tożsamość Microsoft Entra. Wartość AssertionConsumerServiceURL żądania SAML to adres URL wyświetlany w błędzie.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj poniższe kroki:

  1. Upewnij się, że AssertionConsumerServiceURL wartość w żądaniu SAML jest zgodna z wartością Adres URL odpowiedzi skonfigurowaną w Tożsamość Microsoft Entra.
  2. Sprawdź lub zaktualizuj wartość w polu tekstowym Adres URL odpowiedzi, aby była zgodna z wartością AssertionConsumerServiceURL w żądaniu SAML.

Na przykład zapoznaj się z następującym artykułem, aby uzyskać szczegółowe instrukcje dotyczące konfigurowania wartości w Tożsamość Microsoft Entra:

Uwaga

Adres URL odpowiedzi jest również znany jako identyfikator URI przekierowania. Te wartości zależą od używanej aplikacji. Wartości powinny zostać pobrane od dostawcy aplikacji.

Po zaktualizowaniu wartości Adresu URL odpowiedzi w Tożsamość Microsoft Entra i dopasowaniu jej do wartości wysłanej przez aplikację w żądaniu SAML powinno być możliwe zalogowanie się do aplikacji.

Więcej informacji

Aby uzyskać pełną listę kodów błędów uwierzytelniania i autoryzacji usługi Active Directory, zobacz Microsoft Entra kody błędów uwierzytelniania i autoryzacji.

Skontaktuj się z nami, aby uzyskać pomoc

Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii platformy Azure.