Udostępnij za pośrednictwem


Błąd AADSTS650056 — nieprawidłowo skonfigurowana aplikacja

W tym artykule opisano problem polegający na tym, że podczas próby zalogowania się do aplikacji skonfigurowanej do logowania jednokrotnego (SSO) opartej na protokole SAML jest wyświetlany następujący komunikat o błędzie, który został zintegrowany z aplikacją Tożsamość Microsoft Entra:

Błąd AADSTS650056 — nieprawidłowo skonfigurowana aplikacja. Może to być spowodowane jedną z następujących przyczyn: klient nie ma żadnych uprawnień do elementu "{name}" w żądanych uprawnieniach w rejestracji aplikacji klienta. Lub administrator nie wyraził zgody w dzierżawie. Możesz też sprawdzić identyfikator aplikacji w żądaniu, aby upewnić się, że jest on zgodny ze skonfigurowanym identyfikatorem aplikacji klienckiej. Możesz też sprawdzić certyfikat w żądaniu, aby upewnić się, że jest prawidłowy. Skontaktuj się z administratorem, aby naprawić konfigurację lub wyrazić zgodę w imieniu dzierżawy. Identyfikator aplikacji klienckiej: {id}. Skontaktuj się z administratorem, aby naprawić konfigurację lub wyrazić zgodę w imieniu dzierżawy.

Symptomy

Podczas próby zalogowania się do aplikacji, która została skonfigurowana do używania Tożsamość Microsoft Entra do zarządzania tożsamościami przy użyciu logowania jednokrotnego opartego na protokole SAML, występuje błądAADSTS650056.

Przyczyna

Atrybut Issuer wysłany z aplikacji do Tożsamość Microsoft Entra w żądaniu SAML nie jest zgodny z wartością identyfikatora skonfigurowaną dla aplikacji w Tożsamość Microsoft Entra.

Rozwiązanie

Upewnij się, że Issuer atrybut w żądaniu SAML jest zgodny z wartością identyfikatora skonfigurowaną w Tożsamość Microsoft Entra.

Sprawdź, czy wartość w polu tekstowym Identyfikator jest zgodna z wartością identyfikatora wyświetlaną w błędzie.

Aby uzyskać więcej informacji na temat atrybutu Wystawcy, zobacz Single Sign-On SAML protocol (Protokół SAML dla pojedynczego Sign-On).

Więcej informacji

Aby uzyskać pełną listę kodów błędów uwierzytelniania i autoryzacji usługi Active Directory, zobacz Microsoft Entra kody błędów uwierzytelniania i autoryzacji.

Skontaktuj się z nami, aby uzyskać pomoc

Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii platformy Azure.