Wdrożenie nie powiodło się — kod błędu InaccessibleImage
W tym artykule omówiono sposób rozwiązania błędu wdrożenia w usłudze Microsoft Azure Container Instances, który generuje kod błędu "InaccessibleImage".
Symptomy
Podczas próby wdrożenia wystąpienia kontenera wdrożenie kończy się niepowodzeniem i zostanie wyświetlony komunikat o błędzie podobny do następującego tekstu:
{
"code":"DeploymentFailed",
"message":"Co najmniej jedna operacja wdrażania zasobu nie powiodła się. Aby uzyskać szczegółowe informacje, wyświetl listę operacji wdrażania. Zobacz, aby https://aka.ms/DeployOperations uzyskać szczegółowe informacje o użyciu.",
"details":[{
"code":"InaccessibleImage",
"message":"Obraz "<container-registry-name.azurecr.io/<> image-name>:<version-name>" w grupie kontenerów "<container-group-name>" jest niedostępny. Sprawdź poświadczenie obrazu i rejestru".}
]
}
Przyczyna
Próbujesz uzyskać dostęp do rejestru kontenerów platformy Azure przy użyciu jednostki usługi. Ten scenariusz może wystąpić z jednego z następujących powodów:
Podczas próby utworzenia wystąpienia kontenera określono nieprawidłowe poświadczenia.
Określono poprawne poświadczenia, ale wywołania usługi Container Instances są blokowane przez reguły zapory w rejestrze kontenerów platformy Azure.
Rozwiązanie
Aby umożliwić Container Instances zaufanej usłudze dostęp do rejestru kontenerów, należy użyć tożsamości zarządzanej. Aby uzyskać więcej informacji, zobacz Zezwalaj zaufanym usługom na bezpieczny dostęp do rejestru kontenerów z ograniczeniami sieciowymi. Więcej informacji można również znaleźć w temacie Deploy to Azure Container Instances from Azure Container Registry using a managed identity (Wdrażanie w celu Azure Container Instances z Azure Container Registry przy użyciu tożsamości zarządzanej).
Informacje
Ściąganie obrazów usługi Azure Container Apps przy użyciu tożsamości zarządzanej
Samouczek: wdrażanie grupy z wieloma kontenerami przy użyciu szablonu Resource Manager
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii platformy Azure.