Nuta
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
W tym artykule omówiono sposób identyfikowania i rozwiązywania AKSOperationPreempted lub AKSOperationPreemptedByDelete błędów, które mogą wystąpić podczas próby wykonania nowej operacji, ale została ona wywłaszczona przez inną operację w klastrze usługi Microsoft Azure Kubernetes Service (AKS).
Objawy
Podczas próby wykonania nowej operacji w klastrze usługi AKS jest wyświetlany jeden z następujących komunikatów o błędach:
-
Kod: "AKSOperationPreempted"
Komunikat: "Ta operacja została przerwana przez inną operację o identyfikatorze <identyfikator operacji>"
Ten komunikat wskazuje, że operacja została wywłaszona przez inną operację, a identyfikator GUID nowej operacji jest podany w komunikacie o błędzie.
-
Kod: "AKSOperationPreemptedByDelete"
Komunikat: "Ta operacja została przerwana przez operację usuwania".
Ten komunikat wskazuje, że operacja została wstrzymana przez usunięcie.
Przyczyna
Ten błąd zwykle występuje, gdy trwająca operacja zostaje przerwana przez następną, która została rozpoczęta przed jej zakończeniem. Błąd będzie wskazywać kolejną operację, która może być operacją usuwania lub inną operacją.
Rozwiązanie
Aby rozwiązać ten problem, zastosuj jedną z następujących metod: Gdy żadna operacja nie jest uruchomiona, możesz spróbować uruchomić swoją operację ponownie.
Poczekaj na ukończenie poprzedniej operacji.
Stan operacji można sprawdzić przy użyciu identyfikatora podanego w komunikacie o błędzie, używając następującego polecenia:
az aks operation show \ --resource-group myResourceGroup \ --name myCluster \ --operation-id "<operation-id>"Uruchom polecenie
abortaby zatrzymać poprzednią operację.Aby uzyskać więcej informacji na temat przerwania operacji, zobacz Kończenie długotrwałej operacji w klastrze usługi Azure Kubernetes Service (AKS).
Więcej informacji
Ogólne rozwiązywanie problemów związanych z tworzeniem klastrów AKS
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania, możesz zadać pomoc techniczną społeczności platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.