Błąd AADSTS50105 — zalogowany użytkownik nie jest przypisany do roli aplikacji
Ten artykuł zawiera rozwiązanie błędu AADSTS50105 występującego podczas uwierzytelniania federacyjnego z Tożsamość Microsoft Entra.
Uwaga
Czy ten artykuł był pomocny? Twoje dane wejściowe są dla nas ważne. Użyj przycisku Opinie na tej stronie, aby poinformować nas, jak dobrze działa ten artykuł dla Ciebie lub jak możemy go ulepszyć.
Symptomy
Podczas próby zalogowania się do aplikacji skonfigurowanej do używania Tożsamość Microsoft Entra do zarządzania tożsamościami przy użyciu jednokrotnego Sign-On (SSO) opartego na protokole SAML jest wyświetlany następujący komunikat o błędzie:
Błąd AADSTS50105 — zalogowany użytkownik nie jest przypisany do roli aplikacji.
Przyczyna
Użytkownikowi nie udzielono dostępu do aplikacji w Tożsamość Microsoft Entra. Użytkownik musi należeć do grupy przypisanej do aplikacji lub być przypisany bezpośrednio.
Uwaga
Grupy zagnieżdżone nie są obsługiwane, a grupa musi być bezpośrednio przypisana do aplikacji.
Rozwiązanie
Aby bezpośrednio przypisać jednego lub więcej użytkowników do aplikacji, zobacz Szybki start: przypisywanie użytkowników do aplikacji.
Więcej informacji
Aby uzyskać pełną listę kodów błędów uwierzytelniania i autoryzacji usługi Active Directory, zobacz Microsoft Entra kody błędów uwierzytelniania i autoryzacji.
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii platformy Azure.