Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Dotyczy: ✔️ maszyny wirtualne z systemem Windows
Oryginalny numer KB: 4010141
Symptomy
System Windows nie uruchamia się. Zamiast tego system generuje następujący błąd:
Plik: \Windows\System32\config\system
Stan: 0xc000014c
Informacje: nie można załadować systemu operacyjnego, ponieważ brakuje pliku rejestru systemu lub zawiera błędy.
Przyczyna
Ten problem występuje, ponieważ gałąź jest uszkodzona lub nie jest poprawnie zamknięta.
Rozwiązanie
Napiwek
Jeśli masz najnowszą kopię zapasową maszyny wirtualnej, możesz spróbować przywrócić maszynę wirtualną z kopii zapasowej , aby rozwiązać problem z rozruchem.
Aby rozwiązać ten problem, wykonaj następujące kroki.
Napraw uszkodzoną gałąź
- Usuń maszynę wirtualną. Upewnij się, że podczas wykonywania tej czynności wybrano opcję Zachowaj dyski .
- Dołącz dysk systemu operacyjnego jako dysk danych do innej maszyny wirtualnej (maszyna wirtualna rozwiązywania problemów). Aby uzyskać więcej informacji, zobacz How to attach a data disk to a Windows VM in the Azure portal (Jak dołączyć dysk danych do maszyny wirtualnej z systemem Windows w witrynie Azure Portal).
- Nawiąż połączenie z maszyną wirtualną rozwiązywania problemów. Otwórz zarządzanie komputerem Zarządzanie dyskami>. Upewnij się, że dysk systemu operacyjnego jest w trybie online i że jego partycje mają przypisane litery dysku.
- Na dołączonym dysku systemu operacyjnego przejdź do
\windows\system32\config
folderu . Skopiuj wszystkie pliki jako kopię zapasową w przypadku konieczności wycofania. - Na dołączonym dysku systemu operacyjnego skopiuj pliki i
\windows\system32\config\regback
zastąp pliki w pliku\windows\system32\config
. - Odłącz naprawiony dysk systemu operacyjnego od maszyny wirtualnej rozwiązywania problemów. Następnie utwórz nową maszynę wirtualną przy użyciu dysku systemu operacyjnego.
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.