Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Dotyczy: ✔️ maszyny wirtualne z systemem Windows
Ten artykuł zawiera kroki rozwiązywania problemów, w których maszyna wirtualna napotyka nieoczekiwane ponowne uruchomienie lub błąd podczas instalowania systemu Windows.
Objaw
Gdy używasz diagnostyki rozruchu do wyświetlenia zrzutu ekranu maszyny wirtualnej, zobaczysz, że zrzut ekranu przedstawia niepowodzenie instalacji systemu Windows z następującym błędem:
Komputer został nieoczekiwanie uruchomiony ponownie lub napotkał nieoczekiwany błąd. Nie można kontynuować instalacji systemu Windows. Aby zainstalować system Windows, kliknij przycisk OK, aby ponownie uruchomić komputer, a następnie ponownie uruchom instalację.
Przyczyna
Maszyna próbuje wykonać początkowy rozruch uogólnionego obrazu, ale napotka problem z powodu przetworzenia niestandardowego pliku odpowiedzi (Unattend.xml). Pliki odpowiedzi niestandardowych nie są obsługiwane na platformie Azure.
Plik odpowiedzi to specjalny plik XML zawierający definicje ustawień i wartości ustawień konfiguracji, które chcesz zautomatyzować podczas instalacji systemu operacyjnego Windows Server. Opcje konfiguracji zawierają instrukcje dotyczące sposobu partycjonowania dysków, gdzie można znaleźć obraz systemu Windows do zainstalowania, klucze produktów do zastosowania i inne polecenia, które chcesz uruchomić.
Ponownie pliki odpowiedzi niestandardowych nie są obsługiwane na platformie Azure. W związku z tym taka sytuacja występuje, gdy obraz został przygotowany do użycia na platformie Azure, ale określono niestandardowy plik Unattend.xml przy użyciu narzędzia SYSPREP z flagą podobną do następującego polecenia:
sysprep /oobe /generalize /unattend:<your file's name> /shutdown
Na platformie Azure użyj opcji Enter System Out-of-Box Experience (OOBE) w graficznym interfejsie użytkownika narzędzia przygotowywania systemu lub użyj sysprep /oobe
pliku Unattend.xml.
Ten problem jest najczęściej tworzony podczas korzystania z narzędzia sysprep z lokalną maszyną wirtualną do przekazywania uogólnionej maszyny wirtualnej na platformę Azure. W takiej sytuacji może być również zainteresowany tym, jak prawidłowo przekazać uogólnioną maszynę wirtualną.
Rozwiązanie
Spróbuj przywrócić maszynę wirtualną z kopii zapasowej
Jeśli masz najnowszą kopię zapasową maszyny wirtualnej, możesz spróbować przywrócić maszynę wirtualną z kopii zapasowej , aby rozwiązać problem z rozruchem. Jeśli przywracanie maszyny wirtualnej z kopii zapasowej nie jest możliwe, wykonaj kroki opisane w sekcji Nie używaj Unattend.xml .
Nie używaj Unattend.xml
Aby rozwiązać ten problem, postępuj zgodnie ze wskazówkami platformy Azure dotyczącymi przygotowywania/przechwytywania obrazu i przygotowywania nowego uogólnionego obrazu. Podczas narzędzia sysprep nie używaj /unattend:<your file's name>
flagi. Zamiast tego użyj tylko następujących flag:
sysprep /oobe /generalize /shutdown
- Out-of-box-experience (OOBE) to obsługiwane ustawienie dla maszyn wirtualnych platformy Azure.
Możesz również użyć graficznego interfejsu użytkownika narzędzia przygotowywania systemu, aby wykonać to samo zadanie co poprzednie polecenie, wybierając następujące opcje:
- Wprowadź gotowe środowisko
- Uogólnij
- Zamknij
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.