Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Dotyczy: ✔️ maszyny wirtualne z systemem Windows
Ten artykuł zawiera kroki rozwiązywania problemów, w których system Windows nie może uruchomić rozruchu i musi zostać uruchomiony ponownie z powodu nieprawidłowych informacji o konfiguracji systemu na maszynie wirtualnej platformy Azure.
Objaw
Gdy używasz diagnostyki rozruchu do wyświetlenia zrzutu ekranu maszyny wirtualnej, zobaczysz, że na zrzucie ekranu jest wyświetlany kod zatrzymania systemu Windows #0x00000074 lub BAD_SYSTEM_CONFIG_INFO.
Komputer napotkał problem i musi zostać uruchomiony ponownie. Możesz ponownie uruchomić komputer. Aby uzyskać więcej informacji na temat tego problemu i możliwych poprawek, odwiedź stronę Jeśli https://windows.com/stopcode zadzwonisz do osoby pomocy technicznej, podaj im następujące informacje: Zatrzymaj kod: BAD_SYSTEM_CONFIG_INFO
Przyczyna
Kod zatrzymania BAD_SYSTEM_CONFIG_INFO występuje, jeśli gałąź rejestru SYSTEM wydaje się być uszkodzona. Ten błąd może być spowodowany przez dowolną z następujących przyczyn:
- Gałąź rejestru nie została prawidłowo zamknięta.
- Gałąź rejestru jest uszkodzona.
- Brakuje kluczy rejestru lub wartości.
Rozwiązanie
Omówienie procesu
Napiwek
Jeśli masz najnowszą kopię zapasową maszyny wirtualnej, możesz spróbować przywrócić maszynę wirtualną z kopii zapasowej , aby rozwiązać problem z rozruchem.
Napraw uszkodzenie gałęzi.
Włącz zbieranie zrzutów pamięci i konsoli szeregowej.
Ponownie skompiluj maszynę wirtualną.
Uwaga 16.
W przypadku wystąpienia tego błędu system operacyjny gościa nie działa. Aby rozwiązać ten problem, rozwiążesz ten problem w trybie offline.
Naprawianie uszkodzenia gałęzi
Napraw uszkodzony gałąź, wykonując następujące kroki:
Usuń maszynę wirtualną.
Ważne
Po wyświetleniu monitu o potwierdzenie usunięcia maszyny wirtualnej upewnij się, że wyczyść opcję Usuń z maszyną wirtualną skojarzona z typem zasobu dysku systemu operacyjnego.
Dołącz dysk systemu operacyjnego jako dysk danych do innej maszyny wirtualnej (maszyna wirtualna rozwiązywania problemów). Aby uzyskać więcej informacji, zobacz Dołączanie dysku danych zarządzanych do maszyny wirtualnej z systemem Windows przy użyciu witryny Azure Portal.
Nawiąż połączenie z maszyną wirtualną rozwiązywania problemów.
Wybierz pozycję Start, a następnie wyszukaj i wybierz pozycję Zarządzanie komputerem. W drzewie konsoli aplikacji Zarządzanie komputerem wybierz pozycję Zarządzanie dyskami. Upewnij się, że dysk systemu operacyjnego jest w trybie online i że jego partycje mają przypisane litery dysku.
Na dołączonym dysku systemu operacyjnego przejdź do folderu \Windows\System32\config . Skopiuj wszystkie pliki do folderu kopii zapasowej w przypadku konieczności wycofania.
Wybierz pozycję Start, a następnie wyszukaj i wybierz pozycję Edytor rejestru (regedit.exe).
W aplikacji Edytor rejestru wybierz poddrzewo HKEY_USERS, wybierz pozycję Gałąź ładowania plików>w menu, a następnie załaduj plik \Windows\System32\config\SYSTEM.
Jeśli gałąź ładuje się bez problemów, oznacza to, że gałąź nie została poprawnie zamknięta. W takiej sytuacji zwolnij gałąź, aby odblokować plik i rozwiązać problem.
Uwaga 16.
Jeśli zostanie wyświetlony następujący komunikat o błędzie, skontaktuj się z pomocą techniczną platformy Azure:
Nie można załadować <dysku>:\Windows\System32\config\SYSTEM: Błąd podczas ładowania gałęzi
Odłącz naprawiony dysk systemu operacyjnego od maszyny wirtualnej rozwiązywania problemów. Następnie utwórz nową maszynę wirtualną przy użyciu dysku systemu operacyjnego.
Włączanie konsoli szeregowej i kolekcji zrzutów pamięci
Zalecane: Przed odbudową maszyny wirtualnej włącz kolekcję konsoli szeregowej i zrzutu pamięci, wykonując następujące kroki:
Otwórz sesję wiersza polecenia z podwyższonym poziomem uprawnień jako administrator.
Uruchom następujące polecenia BCDEdit przy użyciu opcji /ems i /emssettings :
Włącz konsolę szeregową:
bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
Sprawdź, czy wolne miejsce na dysku systemu operacyjnego jest większe niż rozmiar pamięci RAM na maszynie wirtualnej.
Jeśli na dysku systemu operacyjnego nie ma wystarczającej ilości miejsca, zmień lokalizację, w której jest tworzony plik zrzutu pamięci, i odwołaj się do dowolnego dysku danych dołączonego do maszyny wirtualnej, która ma wystarczającą ilość wolnego miejsca. Aby zmienić lokalizację, zastąp literą
%SystemRoot%
dysku danych, taką jakF:
, w następujących poleceniach.Aby włączyć plik zrzutu systemu operacyjnego, uruchom następujące polecenia ładowania, dodaj i zwolnij , aby zaimplementować sugerowaną konfigurację przy użyciu narzędzia reg :
Załaduj gałąź rejestru z uszkodzonego dysku systemu operacyjnego:
reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
Włącz dla kontrolki ControlSet001:
reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Włącz dla kontrolki ControlSet002:
reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Zwolnij uszkodzony dysk systemu operacyjnego:
reg unload HKLM\<broken-system>
Ponowne kompilowanie maszyny wirtualnej
Użyj kroku 5 poleceń naprawy maszyny wirtualnej, aby ponownie skompilować maszynę wirtualną.
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.