Udostępnij za pośrednictwem


Nic się nie dzieje po kliknięciu linku w programie Internet Explorer

Ostrzeżenie

Wycofana, nieobsługiwana aplikacja klasyczna Internet Explorer 11 ma zostać trwale wyłączona za pośrednictwem aktualizacji aplikacji Microsoft Edge dla niektórych wersji systemu Windows 10. Aby uzyskać więcej informacji, zobacz artykuł pt. Często zadawane pytania dotyczące wycofywania aplikacji klasycznej Internet Explorer 11.

Ten artykuł ułatwia rozwiązanie problemu, którego nie można otworzyć po kliknięciu hiperlinku w programie Internet Explorer.

Oryginalna wersja produktu: Internet Explorer 9
Oryginalny numer KB: 175775

Objawy

Po kliknięciu hiperlinku na stronie internetowej lub w wiadomości e-mail nic się nie dzieje. Program Internet Explorer nie otwiera strony internetowej.

Uwaga

Te informacje dotyczą programu Internet Explorer 9, Internet Explorer 8 i Internet Explorer 7.

Przyczyna

Może się to zdarzyć z co najmniej jednego z następujących powodów:

  • Ustawienie, w którym wybierana jest przeglądarka internetowa, której chcesz użyć, jest uszkodzona. Może to spowodować, że system Windows błędnie zinterpretuje, która przeglądarka jest ustawiona jako domyślna przeglądarka na komputerze.
  • Po zainstalowaniu oprogramowania ustawienia zostały zmienione, co może spowodować nieprawidłowe działanie linków do stron internetowych.
  • Wcześniej zainstalowana przeglądarka lub dodatek może zakłócać inne oprogramowanie na komputerze.
  • Klucze rejestru zostały zmienione lub uszkodzone.

Rozwiązanie

Ta sekcja jest przeznaczona dla początku użytkownika komputera pośredniego. Jeśli te metody nie rozwiążą problemu, możesz wypróbować metody w sekcji Zaawansowane rozwiązywanie problemów. Aby rozwiązać ten problem, użyj następujących metod w kolejności ich prezentowania.

Metoda 1. Sprawdzanie domyślnego ustawienia przeglądarki internetowej

W systemie Microsoft Windows możesz wybrać przeglądarkę internetową, której chcesz użyć. Aby ustawić domyślną przeglądarkę internetową w programie Internet Explorer, wykonaj następujące kroki:

  1. Aby otworzyć program Internet Explorer, kliknij przycisk Start, a następnie kliknij pozycję Internet Explorer.
  2. Jeśli zostanie wyświetlony monit o potwierdzenie, że program Internet Explorer ma być przeglądarką domyślną, kliknij przycisk Tak.
  3. W menu Narzędzia kliknij pozycję Opcje internetowe.
  4. Kliknij przycisk Programy>Ustaw jako domyślne>, a następnie zamknij program Internet Explorer.

Uwaga

Zmiany zostaną wprowadzone przy następnym uruchomieniu programu Internet Explorer.

Sprawdź, czy problem został rozwiązany. Jeśli problem zostanie rozwiązany, skończysz z tym artykułem. Jeśli problem nie został rozwiązany, spróbuj wykonać następną metodę.

Metoda 2. Zmiana typów plików otwieranych domyślnie w programie Internet Explorer

W systemach Windows 7 i Windows Vista.

  1. Zamknij wszystkie okna programu Internet Explorer.
  2. Kliknij przycisk Start, a następnie kliknij przycisk Panelu sterowania.
  3. Kliknij pozycję Programy, a następnie kliknij pozycję Ustaw programy domyślne.
  4. W menu Programy kliknij pozycję Internet Explorer, a następnie kliknij pozycję Wybierz wartości domyślne dla tego programu.
  5. Upewnij się, że zaznaczono pola wyboru .htm, .htmli urls , a następnie kliknij przycisk Zapisz.
  6. Kliknij przycisk OK.

Uwaga

Zmiany zostaną wprowadzone przy następnym uruchomieniu programu Internet Explorer.

W przypadku systemu Windows XP

  1. Aby otworzyć Eksploratora Windows, kliknij prawym przyciskiem myszy przycisk Start, a następnie kliknij pozycję Mój komputer.

  2. W menu Narzędzia kliknij pozycję Opcje folderów, a następnie kliknij kartę Typy plików.

  3. Znajdź i wybierz typ pliku HTM.

  4. Upewnij się, że program Internet Explorer jest wybrany jako otwierany z programem. Jeśli program Internet Explorer nie jest zaznaczony, kliknij przycisk Zmień, wybierz program Internet Explorer jako zalecany program, a następnie kliknij przycisk OK.

  5. Powtórz kroki 3 i 4 dla następujących typów plików:

    • HTML
    • ITS
    • MHT
    • MTHML
    • XML
    • XSL

Sprawdź, czy problem został rozwiązany. Jeśli problem zostanie rozwiązany, skończysz z tym artykułem. Jeśli problem nie został rozwiązany, przejdź do następnej metody.

Metoda 3. Używanie trybu dodatków programu Internet Explorer

Mimo że dodatki przeglądarki mogą poprawić środowisko online, mogą one czasami zakłócać lub powodować konflikt z innym oprogramowaniem na komputerze. Należy jednak pamiętać, że niektóre strony internetowe lub sam program Internet Explorer mogą nie być wyświetlane poprawnie, jeśli dodatek jest wyłączony. Najpierw uruchom program Internet Explorer z tymczasowo wyłączonymi dodatkami, aby sprawdzić, czy problem został rozwiązany. (Dodatki będą wyłączone tylko do momentu ponownego uruchomienia programu Internet Explorer w zwykły sposób). W tym celu wykonaj następujące kroki:

  • Kliknij przycisk Start, wpisz Internet Explorer w polu Wyszukiwania, a następnie kliknij pozycję Internet Explorer (brak dodatków).

    Uwaga

    W systemie Windows XP kliknij przycisk Start , kliknij prawym przyciskiem myszy ikonę programu Internet Explorer , a następnie kliknij przycisk Przeglądaj bez dodatków.

Jeśli tryb dodatku programu Internet Explorer nie rozwiąże problemu, wykonaj następujące kroki, aby zidentyfikować dodatek przeglądarki, który powoduje problem:

  1. Aby uruchomić program Internet Explorer, kliknij przycisk Start, a następnie kliknij pozycję Internet Explorer.
  2. Kliknij przycisk Narzędzia, a następnie kliknij pozycję Zarządzaj dodatkami.
  3. Kliknij dodatek na liście Nazwa, a następnie kliknij pozycję Wyłącz. Przetestuj program Internet Explorer.
  4. Powtórz krok 3, dopóki nie zidentyfikujesz dodatku, który powoduje problem.

Sprawdź, czy problem został rozwiązany. Jeśli problem zostanie rozwiązany, skończysz z tym artykułem. Jeśli problem nie został rozwiązany, spróbuj wykonać następną metodę.

Metoda 4. Resetowanie ustawień programu Internet Explorer

Jeśli problem jest spowodowany uszkodzonymi lub niezgodnymi ustawieniami programu Internet Explorer lub dodatkami, zazwyczaj można rozwiązać ten problem, resetując ustawienia programu Internet Explorer do ustawień domyślnych.

Po zresetowaniu ustawień programu Internet Explorer wszystkie poprzednie ustawienia zostaną utracone i nie można ich odzyskać. Po przywróceniu domyślnych ustawień programu Internet Explorer niektóre strony internetowe korzystające z przechowywanych plików cookie, danych formularza, haseł lub wcześniej zainstalowanych dodatków przeglądarki mogą nie działać poprawnie. Jednak zresetowanie programu Internet Explorer do ustawień domyślnych nie powoduje usunięcia ulubionych, kanałów informacyjnych i kilku innych ustawień osobistych.

Aby zresetować ustawienia programu Internet Explorer, wykonaj następujące kroki:

  1. Zamknij wszystkie okna programu Internet Explorer.

  2. Kliknij przycisk Start, wpisz inetcpl.cpl w polu Wyszukaj, a następnie kliknij inetcpl.cpl na liście Programy. Zostanie wyświetlone okno dialogowe Opcje internetowe.

    Uwaga

    w systemie Windows XP kliknij przycisk Start, kliknij przycisk Uruchom, wpisz inetcpl.cpl w polu Otwórz, a następnie kliknij przycisk OK.

  3. Kliknij kartę Zaawansowane.

  4. W obszarze Resetuj ustawienia programu Internet Explorer kliknij pozycję Resetuj. Następnie kliknij ponownie pozycję Resetuj .

  5. Po zakończeniu resetowania programu Internet Explorer kliknij przycisk Zamknij w oknie dialogowym Resetowanie ustawień programu Internet Explorer.

  6. Uruchom ponownie program Internet Explorer. Zmiany zostaną wprowadzone przy następnym otwarciu programu Internet Explorer.

Metoda 5. Ponowne zarejestrowanie niezbędnych plików DLL programu Internet Explorer

Uwaga

Te informacje dotyczą systemu Windows XP

Aby ponownie zarejestrować pliki DLL, wykonaj następujące kroki:

  1. Kliknij przycisk Start, kliknij pozycję Wszystkie programy, kliknij pozycję Akcesoria, kliknij prawym przyciskiem myszy polecenie cmd, a następnie wybierz polecenie Uruchom jako administrator. Jeśli zostanie wyświetlony monit o hasło administratora lub potwierdzenie, wpisz hasło lub potwierdź.

  2. Wpisz regsvr32 urlmon.dll w polu Otwórz, a następnie kliknij przycisk OK.

  3. Po otrzymaniu potwierdzenia kliknij przycisk OK .

  4. Powtórz kroki 2 i 3 dla następujących poleceń:

    • regsvr32 mshtml.dll
    • regsvr32 shdocvw.dll
    • regsvr32 browseui.dll
    • regsvr32 msjava.dll

Sprawdź, czy problem został rozwiązany. Jeśli problem zostanie rozwiązany, skończysz z tym artykułem. Jeśli problem nie został rozwiązany, przejdź do następnej sekcji.

Zaawansowane rozwiązywanie problemów

Ta sekcja jest przeznaczona dla bardziej zaawansowanych użytkowników komputerów.

Metoda 1. Tworzenie nowego konta użytkownika

Aby uzyskać więcej informacji na temat profilów użytkowników, zobacz About User Profiles (Informacje o profilach użytkowników).

Aby uzyskać szczegółowe informacje o metodzie, przejdź do następujących witryn internetowych firmy Microsoft:

Metoda 2. Korzystanie z przywracania systemu

Przywracanie systemu używa punktów przywracania w celu zwrócenia plików systemowych i ustawień do wcześniejszego punktu w czasie bez wpływu na pliki osobiste. Punkty przywracania są tworzone automatycznie co tydzień i tuż przed znaczącymi zdarzeniami systemowym, takimi jak instalacja programu, urządzenie lub sterownik.

Przed rozpoczęciem przywracania systemu zapisz wszystkie otwarte pliki i zamknij wszystkie programy. Po potwierdzeniu punktu przywracania przywracanie przywracanie systemu powoduje ponowne uruchomienie komputera. Aby wykonać przywracanie systemu, wykonaj następujące kroki:

W przypadku systemów Windows 7 i Windows Vista

  1. Kliknij przycisk Start, kliknij pozycję Wszystkie programy, kliknij pozycję Akcesoria, kliknij pozycję Narzędzia systemowe, a następnie kliknij pozycję Przywracanie systemu. Jeśli zostanie wyświetlony monit o hasło administratora lub potwierdzenie, wpisz hasło lub potwierdź.

  2. Kliknij przycisk Dalej na stronie Przywracanie systemu.

  3. Wybierz odpowiednią datę lub opis przywracania systemu.

    Uwaga

    Jeśli nie widzisz określonej daty, której szukasz, wybierz pozycję Pokaż więcej dat, a następnie wybierz odpowiednią datę.

  4. W oknie potwierdzenia kliknij przycisk Zakończ. Komputer zostanie uruchomiony ponownie. Po zakończeniu procesu zostanie wyświetlony komunikat z potwierdzeniem.

W przypadku systemu Windows XP

  1. Zaloguj się do systemu Windows przy użyciu konta z uprawnieniami administracyjnymi.
  2. Kliknij przycisk Start, kliknij pozycję Wszystkie programy, kliknij pozycję Akcesoria, kliknij pozycję Narzędzia systemowe, a następnie kliknij pozycję Przywracanie systemu.
  3. Na stronie Witamy w przywracaniu systemu wybierz opcję Przywróć mój komputer do wcześniejszego czasu , a następnie kliknij przycisk Dalej.
  4. Na stronie Wybierz punkt przywracania kliknij najnowszy punkt przywracania systemu na tej liście, kliknij listę punktów przywracania, a następnie kliknij przycisk Dalej.
  5. Na stronie Potwierdzanie zaznaczenia punktu przywracania kliknij przycisk Dalej. Przywracanie systemu przywraca poprzednią konfigurację systemu Windows XP, a następnie ponownie uruchamia komputer.
  6. Zaloguj się na komputerze jako administrator. Następnie kliknij przycisk OK na stronie Przywracanie przywracania systemu Ukończono. Komputer zostanie uruchomiony ponownie. Po zakończeniu procesu zostanie wyświetlony komunikat z potwierdzeniem.

Jeśli używasz przywracania systemu, ale problem nadal występuje lub występują inne problemy, możesz cofnąć operację przywracania. Po cofnięciu operacji możesz spróbować użyć innego punktu przywracania. Aby cofnąć operację przywracania systemu, wykonaj następujące kroki:

  1. Kliknij przycisk Start, kliknij pozycję Wszystkie programy, kliknij pozycję Akcesoria, kliknij pozycję Narzędzia systemowe, a następnie kliknij pozycję Przywracanie systemu.
  2. Kliknij przycisk Cofnij przywracanie systemu, a następnie kliknij przycisk Dalej.
  3. Przejrzyj wybrane opcje, a następnie kliknij przycisk Zakończ.

Komputer zostanie uruchomiony ponownie. Po zakończeniu procesu otrzymasz potwierdzenie.

Dodatkowe zasoby

Sprawdź, czy problem został rozwiązany. Jeśli problem zostanie rozwiązany, skończysz z tym artykułem. Jeśli problem nie został rozwiązany, możesz również użyć usług pomocy technicznej firmy Microsoft, aby znaleźć inne rozwiązania. pomoc techniczna firmy Microsoft usługi obejmują następujące metody:

  • Wyszukaj bazę wiedzy Microsoft Knowledge Base: znajdź informacje o pomocy technicznej i narzędzia do samodzielnej pomocy dla produktów firmy Microsoft.
  • Centra rozwiązań: wyświetlanie konkretnych produktów, często zadawanych pytań i wyróżnianie pomocy technicznej.
  • Społeczność firmy Microsoft: kontaktowanie się z odpowiednikami, elementami równorzędnymi i specjalistami firmy Microsoft (MVP).
  • Inne opcje pomocy technicznej: Zadaj pytanie, skontaktuj się z pomocą techniczną firmy Microsoft lub prześlij opinię.