Udostępnij za pośrednictwem


Błąd podczas zmiany tożsamości puli aplikacji przy użyciu Menedżera usług IIS z komputera zdalnego: zestaw kluczy nie istnieje

Ten artykuł usuwa błąd zestawu kluczy nie istnieje . Ten błąd występuje, gdy zmieniasz tożsamość puli aplikacji przy użyciu Menedżera usług Microsoft Internet Information Services (IIS) z komputera zdalnego.

Oryginalna wersja produktu: Windows Server 2008, Windows Server 2008 R2
Oryginalny numer KB: 977754

Symptomy

Rozważmy następujący scenariusz:

  • Na serwerze z systemem Windows Server 2008 lub Windows Server 2008 R2 włącz zdalne zarządzanie usługami IIS.
  • Serwer ma więcej niż jedną pulę aplikacji skonfigurowaną w usługach IIS.
  • Jedna z pul aplikacji jest skonfigurowana do używania niestandardowej tożsamości użytkownika.
  • Menedżer usług IIS służy do nawiązywania połączenia z serwerem jako administrator z komputera zdalnego.

W tym scenariuszu, gdy próbujesz zmienić tożsamość dowolnej puli aplikacji, zostanie wyświetlony następujący komunikat o błędzie:

Wystąpił błąd podczas wykonywania tej operacji.
Szczegóły:
Zestaw kluczy nie istnieje (wyjątek od HRESULT: 0x80090016)

Przyczyna

Konto USŁUGI LOKALNEJ to konto usługi Usługa zarządzania siecią Web usług IIS (nazywane również WMSvc). Ten problem występuje, ponieważ konto USŁUGI LOKALNEJ nie ma dostępu do odczytu w kluczu iisWasKey znajdującym się w folderze %ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys .

Oto nazwa iisWasKey pliku klucza:
76944fb33636aeddb9590521c2e8815a_GUID

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące kroki:

  1. Znajdź folder %ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys.
  2. Kliknij prawym przyciskiem myszy plik 76944fb33636aeddb9590521c2e8815a_GUID , a następnie wybierz polecenie Właściwości.
  3. Wybierz kartę Zabezpieczenia , a następnie wybierz pozycję Edytuj. Jeśli zostanie wyświetlony monit o kontynuowanie operacji, wybierz pozycję Kontynuuj. Następnie w oknie dialogowym Uprawnienia zostanie wyświetlona lista nazw grup i nazw użytkowników, które mają dostęp do tego pliku klucza.
  4. Wybierz Dodaj. Następnie zostanie wyświetlone okno dialogowe Wybieranie użytkowników, komputerów, kont usług lub grup.
  5. Wpisz LOCAL SERVICE, a następnie wybierz pozycję Sprawdź nazwy.
  6. Wybierz przycisk OK.
  7. Na liście Nazwy grup lub użytkowników wybierz pozycję USŁUGA LOKALNA. Upewnij się, że pole wyboru Odczyt jest zaznaczone na liście Uprawnienia dla usługi LOKALNEJ.
  8. Wybierz przycisk OK.

Więcej informacji

Ten problem został rozwiązany w systemie Windows Server 2008 z dodatkiem Service Pack 2.