Udostępnij za pośrednictwem


Jak administratorzy systemów mogą rozwiązywać problemy z komunikatem o błędzie HTTP „404 — Nie odnaleziono pliku” na serwerze z programem IIS

Ten artykuł pomaga rozwiązać problem polegający na tym, że nie znaleziono pliku błędu HTTP 404 na serwerze z uruchomionymi usługami Internet Information Services (IIS).

Uwaga 16.

Ten artykuł jest przeznaczony dla administratorów witryn sieci Web. Użytkownicy końcowi, którzy doświadczają tych błędów, powinni powiadomić administratora witryny sieci Web o problemie.

Oryginalna wersja produktu: Internet Information Services
Oryginalny numer KB: 248033

Symptomy

Po zażądaniu strony sieci Web w górnej części przeglądarki internetowej zostanie wyświetlony następujący komunikat o błędzie:

Nie można odnaleźć strony
Strona, której szukasz, mogła zostać usunięta, miała zmienioną nazwę lub jest tymczasowo niedostępna.

Na stronie sieci Web zostanie wyświetlony następujący komunikat o błędzie:

HTTP 404 — nie znaleziono pliku
Internet Information Services

Przyczyna

Serwer sieci Web zwraca komunikat o błędzie HTTP 404 — nie znaleziono pliku, gdy nie może pobrać żądanej strony.

Poniżej przedstawiono niektóre typowe przyczyny tego komunikatu o błędzie:

  • Nazwa żądanego pliku została zmieniona.
  • Żądany plik został przeniesiony do innej lokalizacji i/lub usunięty.
  • Żądany plik jest tymczasowo niedostępny z powodu konserwacji, uaktualnień lub innych nieznanych przyczyn.
  • Żądany plik nie istnieje.
  • IIS 6.0: odpowiednie rozszerzenie usługi sieci Web lub typ MIME nie jest włączone.
  • Katalog wirtualny jest mapowany na katalog główny dysku na innym serwerze.

Rozwiązanie

Aby rozwiązać ten problem, sprawdź, czy plik żądany w adresie URL przeglądarki istnieje na komputerze usług IIS i czy znajduje się w prawidłowej lokalizacji.

Za pomocą przystawki programu MICROSOFT Management Console (MMC) usług IIS określ, gdzie plik, którego zażądano, musi istnieć w systemie plików komputera usług IIS.

Jest to ważne, jeśli witryna sieci Web używa katalogu wirtualnego (VDIR). VDIR to katalog, który nie znajduje się w katalogu głównym witryny sieci Web, ale wygląda na to, że jest to przeglądarka kliencka. Ten katalog wirtualny musi być zamapowany na podfolder na dysku lub odwoływać się do plików według nazwy.

Załóżmy na przykład, że adres URL, który spowodował błąd 404, to http://Microsoft.Com/Test/File1.htm, a przystawka USŁUG IIS pokazuje, że dla Microsoft.Com witryny sieci Web katalog /Test/ jest w rzeczywistości katalogiem wirtualnym mapowanym na lokalizację c:\Information na komputerze usług IIS. Oznacza to, że należy sprawdzić, czy plik File1.htm znajduje się w katalogu c:\Information (i czy nazwa pliku jest poprawnie wpisana).

Zawartość dynamiczna usług IIS: wpis 404.2 w rozszerzonym pliku dziennika W3C jest rejestrowany, gdy rozszerzenie sieci Web nie jest włączone. Użyj przystawki Microsoft Management Console (MMC) usług IIS, aby włączyć odpowiednie rozszerzenie sieci Web. Domyślne rozszerzenia sieci Web obejmują: ASP, ASP.NET, dołączanie po stronie serwera, publikowanie WebDAV, rozszerzenia serwera programu FrontPage, wspólny interfejs bramy (CGI). Rozszerzenia niestandardowe muszą być dodawane i jawnie włączone. Aby uzyskać więcej informacji, zobacz plik Pomocy usług IIS.

Zawartość statyczna usług IIS: wpis 404.3 w pliku dziennika rozszerzonego W3C jest rejestrowany, gdy rozszerzenie nie jest mapowane na znane rozszerzenie we właściwości MAP MIME. Za pomocą przystawki programu MICROSOFT Management Console (MMC) usług IIS skonfiguruj odpowiednie rozszerzenie w mapie MIME. Aby uzyskać więcej informacji, zobacz plik Pomocy usług IIS.

Aby uzyskać więcej informacji o innych, mniej typowych przyczynach tego komunikatu o błędzie, zobacz Ukryte pliki statyczne usług IIS zwracają błędy HTTP 404 lub Odmowa dostępu.

Więcej informacji