Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Ten artykuł ułatwia rozwiązanie problemu polegającego na tym, że przeglądarki internetowe nie mogą łączyć się z witryną internetową przy użyciu protokołu Secure Sockets Layer (SSL) w programie Internet Explorer.
Oryginalna wersja produktu: Internet Information Services 8.0, Internet Explorer 10, Internet Explorer 9
Oryginalny numer KB: 2744241
Symptomy
Masz zainstalowaną przeglądarkę internetową na komputerze z systemem operacyjnym Windows. Spróbujesz użyć przeglądarki internetowej, aby wyświetlić witrynę internetową za pośrednictwem bezpiecznego połączenia protokołu SECURE Sockets Layer (SSL)/Hypertext Transfer Protocol Secure (HTTPS). W tej konfiguracji nie można nawiązać połączenia z witryną internetową za pośrednictwem protokołu SSL/HTTPS. Gdy wystąpi problem, użytkownicy mogą zobaczyć komunikat o błędzie podobny do następującego, w zależności od wersji przeglądarki internetowej:
Nie można odnaleźć serwera lub błędu DNS
lub
Wystąpił problem z certyfikatem bezpieczeństwa tej witryny. Problemy z certyfikatem zabezpieczeń mogą wskazywać na próbę oszukania użytkownika lub przechwycenia wszelkich danych wysyłanych do serwera
lub
Program Internet Explorer nie może wyświetlić strony internetowej
W przypadku wystąpienia problemu możesz wyświetlić tę samą witrynę internetową za pośrednictwem standardowego połączenia protokołu HTTP (HyperText Transfer Protocol) (które nie korzysta z protokołu SSL) i możesz wyświetlić inne witryny internetowe za pośrednictwem połączenia SSL/HTTPS.
Przyczyna
Problem występuje, ponieważ witryna internetowa, do której klient próbuje przejść przez protokół SSL, ma certyfikat zabezpieczeń RSA, który używa kluczy kryptograficznych o długości mniejszej niż 1024 bitów. Aby uzyskać więcej informacji na temat wpływu zabezpieczeń związanego ze zmianami wprowadzonych przez KB2661254, zobacz Microsoft Security Advisory 2661254.
Rozwiązanie
Aby rozwiązać ten problem, zobacz 2661254 biuletynu zabezpieczeń firmy Microsoft.
Jeśli jesteś administratorem witryny internetowej, a witryna internetowa jest uruchomiona w usługach Microsoft Internet Information Services (IIS), zobacz sekcję Więcej informacji poniżej, aby uzyskać informacje na temat uzyskiwania i instalowania certyfikatów SSL.