Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Ten artykuł zawiera rozwiązania, które odpowiadają przyczynom problemu, gdy otrzymujesz błędy inicjalizacji podczas usuwania lub instalowania Menedżera Integracji w programie Microsoft Dynamics GP.
Dotyczy: Microsoft Dynamics GP
Oryginalny numer KB: 861816
Symptomy
Podczas usuwania lub instalowania programu Integration Manager podczas inicjowania konfiguracji mogą wystąpić następujące błędy:
- Błąd podczas wyodrębniania plików pomocy technicznej
- Błąd podczas instalowania Ikernel.exe (0x dowolna liczba)
- Odmowa dostępu
- Błąd podczas ładowania biblioteki typów lub biblioteki DLL
Przyczyna
Błędy inicjowania konfiguracji mogą być spowodowane wieloma czynnikami. Jest to niewyczerpująca lista możliwych przyczyn:
- Nie masz wystarczających uprawnień na komputerze.
- Jeśli po prostu uruchomiono instalację InstallShield, czyszczenie aparatu trwa kilka sekund na końcu instalacji.
- Ikernel.exe jest w pamięci.
- W folderze tymczasowym znajdują się dodatkowe pliki.
- Folder Program Files\Common Files\InstallShield\Engine istnieje.
- Pliki podstawowe systemu Windows są uszkodzone lub brakuje.
- Brak pliku Stdole32.tlb.
- Nie masz wystarczających uprawnień COM.
Rozwiązanie
Aby rozwiązać ten problem, użyj metody odpowiadającej przyczynie problemu.
Nie masz wystarczających uprawnień na komputerze.
Jeśli używasz komputera z systemem Microsoft Windows 2000, komputera z systemem Windows XP lub komputera z systemem Windows 2003, musisz mieć uprawnienia administracyjne do uruchomienia instalacji InstallShield Professional 6.x. Upewnij się, że masz odpowiednie uprawnienia.
Jeśli po prostu uruchomiono instalację InstallShield, czyszczenie aparatu trwa kilka sekund na końcu instalacji.
W tym czasie Ikernel.exe (plik aparatu) jest nadal aktywny w pamięci z poprzedniego procesu; dlatego nie można uruchomić innej instalacji. Zaczekaj kilka sekund, a następnie ponownie uruchom instalatora.
Ikernel.exe jest w pamięci.
Upewnij się, że Ikernel.exe nie znajduje się w pamięci. Jeśli tak jest, a konfiguracja nie jest uruchomiona w tym czasie, zakończ to zadanie.
W folderze tymczasowym znajdują się dodatkowe pliki.
Wyczyść folder tymczasowy.
Folder Program Files\Common Files\InstallShield\Engine istnieje.
Usuń folder Program Files\Common Files\InstallShield\Engine, a następnie ponownie uruchom instalatora.
Pliki podstawowe systemu Windows są uszkodzone lub brakuje.
Ponowne zainstalowanie programu Internet Explorer 6.x lub nowszej wersji spowoduje naprawienie wielu uszkodzonych/brakujących podstawowych plików systemu Windows z komputera. W związku z tym zaleca się ponowne zainstalowanie programu Internet Explorer 6.x lub nowszej oraz najnowszego dodatku Service Pack systemu Windows.
Brak pliku Stdole32.tlb.
Jest to podstawowy plik systemu Windows i musi istnieć na komputerze. Upewnij się, że masz ten plik lub pobierz ten plik z innego komputera, na którym działa ten sam system operacyjny co komputer docelowy.
Nie masz wystarczających uprawnień COM.
Jeśli zostanie wyświetlony błąd Błąd podczas instalowania Ikernel.exe, odmowa dostępu jest błędem , wykonaj następujące kroki, aby udzielić sobie niezbędnych uprawnień:
- W oknie wiersza polecenia wpisz dcomcnfg.exe. W tym kroku zostanie otwarte okno dialogowe Właściwości konfiguracji rozproszonego modelu COM.
- Wybierz kartę Domyślne zabezpieczenia.
- W sekcji Domyślne uprawnienia dostępu wybierz przycisk Edytuj domyślne .
- Upewnij się, że obok nazwy użytkownika jest wyświetlana pozycja "Zezwalaj na dostęp". Jeśli pozycja "Zezwalaj na dostęp" nie jest wyświetlana obok nazwy użytkownika, zmodyfikuj istniejący profil. Możesz też utworzyć nowy profil, który ma niezbędne uprawnienia.
- Zastosuj wszystkie zmiany, a następnie ponownie uruchom instalatora.