Udostępnij za pośrednictwem


"Wpis dziennika jest niedostępny" jest wyświetlany w oknie Journal Entry Inquiry

Ten artykuł zawiera rozwiązanie problemu, który występuje, gdy podczas wyświetlania wpisu dziennika w oknie Zapytanie wpisu dziennika pojawia się komunikat, że wpis dziennika nie jest dostępny.

Dotyczy: Microsoft Dynamics GP
Oryginalny numer KB: 2397557

Symptomy

Podczas próby wyświetlenia wpisu dziennika w oknie Journal Entry Inquiry wyświetlany jest następujący komunikat:

Wpis dziennika jest niedostępny.

Przyczyna

Istnieje kilka powodów, dla których ten komunikat może się zdarzyć:

  1. Produkt innej firmy zakłóca działanie — zobacz Metoda 1 w sekcji Rozwiązanie.
  2. Transakcja wpisu dziennika została usunięta z tabeli GL — zobacz Metodę 2 w sekcji Rozwiązanie poniżej.
  3. Z jakiegokolwiek innego powodu otwórz zgłoszenie do pomocy technicznej, aby uzyskać dalszą pomoc i dołączyć Dexsql.log w metodzie 3.

Rozwiązanie

Poniżej przedstawiono możliwe wyjaśnienia, dlaczego dziennik Entry (JE) może nie być dostępny do wyświetlenia:

Metoda 1 — produkt innej firmy może spowodować, że wpis dziennika nie będzie wyświetlany

Aby przetestować, wykonaj następujące kroki:

  1. W menu Microsoft Dynamics GP wskaż pozycję Narzędzia, wskaż polecenie Dostosuj i wybierz pozycję Stan dostosowywania.

  2. Wybierz dowolny produkt innej firmy, a następnie wybierz pozycję Wyłącz. (Możesz pozostawić usługę Microsoft Dynamics GP włączoną, ale można wyłączyć wszystkie inne. Mimo że wszystkie inne produkty firmy Microsoft powinny być zgodne. Wyłącz wszystkie rozpoznawane produkty innych firm.

  3. Zamknij okno.

  4. Teraz przetestuj ściągnięcie wpisu Dziennika ponownie. (Może być konieczne powrót i wybranie pozycji Włącz dla kilku modułów i kontynuowanie testowania, dopóki nie znajdziesz modułu, który powoduje problem).

Uwaga 16.

Wyłączenie modułów w oknie Stan dostosowywania jest tymczasowe. W związku z tym, jeśli wyjdziesz z programu Microsoft Dynamics GP i zalogujesz się ponownie, wszystkie produkty zostaną automatycznie włączone ponownie.

Metoda 2 — sprawdzanie, czy transakcja istnieje w tabelach General Ledger (GL)

Jeśli brakuje go w otwartej tabeli, wyjaśni to, dlaczego nie ściągnie. W tym celu wykonaj następujące kroki:

  1. Otwórz SQL Server Management Studio.

  2. Wybierz pozycję Nowe zapytanie na górnym pasku menu.

  3. Wybierz bazę danych firmy z listy rozwijanej.

  4. Skopiuj w tych skryptach, aby wyszukać transakcję w tabeli Open table (GL20000 transakcji GL to_Date) lub tabeli Historia transakcji konta GL (GL30000). Wykonaj te skrypty względem firmowej bazy danych, aby znaleźć miejsce, w którym znajduje się wpis dziennika.

    Select * from GL20000 where JRNENTRY = 'xxx' (insert in the JE# for the xxx placeholder)
    Select * from GL30000 where JRNENTRY = 'xxx' (insert in the JE# for the xxx placeholder)
    

    Uwaga 16.

    Należy uzyskać co najmniej dwa wiersze zwrócone z otwartej tabeli: każdy wpis dziennika będzie miał co najmniej jeden rekord debetowy i jeden rekord kredytowy. Jeśli nie otrzymasz żadnych zwróconych wyników, wpis dziennika został usunięty z tabeli GL, co wyjaśnia, dlaczego nie możesz go wyświetlić.

    Okno Journal Entry Inquiry zostało zaprojektowane tak, aby ściągnąć z otwartej tabeli. Więc jeśli znajdziesz go w tabeli historii, nie będzie można go wyświetlić przy użyciu okna Zapytanie wpisu dziennika. Wpisy dziennika historycznego można wyświetlać tylko przy użyciu listy inteligentnej.

Metoda 3 — z dowolnego innego powodu włącz dexsql.log próby wyświetlenia wpisu dziennika i otwórz nowy przypadek pomocy technicznej, aby uzyskać dalszą pomoc

  1. Włącz dexsql.log, wykonując kroki opisane w temacie Jak utworzyć plik Dexsql.log w celu rozwiązywania problemów z komunikatami o błędach w programie Microsoft Dynamics GP.

  2. Zaloguj się do usługi Microsoft Dynamics GP i wybierz pozycję Zapytanie, wskaż pozycję Financial i wybierz pozycję Zapytanie dotyczące wpisu dziennika.

  3. Wpisz numer wpisu dziennika i zatrzymaj.

  4. Usuń dexsql.log, który został utworzony w tym punkcie w folderze kodu gp, ponieważ nie potrzebujemy żadnych danych w dzienniku do tego momentu.

  5. W oknie Zapytanie dotyczące wpisu dziennika wybierz przycisk OK , aby odtworzyć komunikat. Zatrzymaj się tam.

  6. Przejdź do folderu kodu gp i natychmiast zmień nazwę dexsql.log, który został utworzony, więc nie zapisujesz żadnych innych czynności w programie Microsoft Dynamics GP w tym dzienniku.

  7. Otwórz zgłoszenie do pomocy technicznej i dołącz dexsql.log do zgłoszenia do przeglądu.