Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Ten artykuł zawiera opcje rozwiązywania problemu, w którym znaki cudzysłowu pojawiają się wokół wartości w pliku .csv dla Bezpiecznej płatności w Microsoft Dynamics GP.
Dotyczy: Microsoft Dynamics GP
Oryginalny numer KB: 2511178
Symptomy
Znaki cudzysłowu są wyświetlane wokół każdej wartości w polu w pliku Safe Pay wygenerowanym jako plik rozdzielany przecinkami (.csv) w usłudze Microsoft Dynamics GP. Bank chce usunąć tylko wartości liczbowe między przecinkami a cudzysłowami.
Przyczyna
Jeśli format pliku jest ustawiony na rozdzielany przecinkami, spowoduje to umieszczenie cudzysłowów wokół tekstu. Jest to celowe.
Rozwiązanie
Usługa Safe Pay nie ma opcji wygenerowania pliku rozdzielanego przecinkami, który nie ma podwójnych cudzysłowów wokół pól. Cudzysłowy zostaną umieszczone wokół pól tekstowych. Aby obejść ten problem, użyj jednej z poniższych opcji.
Opcja 1
Skonfiguruj konfigurator Safe Pay jako plik o stałej długości, a następnie zakoduj przecinek między poszczególnymi polami jako stałą. Obecnie tylko format o stałej długości pomija cudzysłowy w polu tekstowym. Większość banków zaakceptuje również plik .txt. Upewnij się jednak, że bank zaakceptuje to najpierw. Ta opcja wymaga początkowego czasu, aby ponownie skonfigurować plik konfiguracyjny, ale następnie plik zostanie wygenerowany poprawnie bez cudzysłowów w przyszłości.
Opcja 2
Pozostaw konfigurator Safe Pay jako typ pliku rozdzielanego przecinkami. Otwórz plik w Notatniku przed wysłaniem go za każdym razem. Użyj polecenia Znajdź, aby znaleźć każdy cudzysłów (") i zastąpić go niczym. Wymagałoby to ręcznej edycji dla każdego wysłanego pliku.
Opcja 3
Zamów usługę dostosowania pliku, aby samodzielnie usunąć cudzysłowy z wygenerowanego pliku .csv. Możesz też znaleźć produkt innej firmy zgodny z dynamics GP, który może osiągnąć potrzebny format pliku.