Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Ten artykuł zawiera rozwiązanie błędu występującego podczas korzystania z dzienników inspekcji w programie Microsoft Dynamics GP.
Dotyczy: Microsoft Dynamics GP
Oryginalny numer KB: 2450782
Symptomy
Użytkownik, który ma uprawnienia dziennika inspekcji, nie może już uzyskiwać dostępu do dzienników inspekcji ani uruchamiać raportów dziennika inspekcji. Na przykład w oknie Widok inteligentny w dziennikach inspekcji te komunikaty występują (odwołując się do aliasu użytkownika dla xxxxx i odpowiedniej bazy danych inspekcji dla XXXXX):
Błąd GPS epAuditTrailView I_PB_Refresh_CHG: 10
Błąd SQL epAuditTrailView I_PB_Refresh_CHG: 916
Podmiot zabezpieczeń serwera "xxxxx" nie może uzyskać dostępu do bazy danych "XXXXX" w bieżącym kontekście zabezpieczeń.
Błąd ODBC epAuditTrailView I_PB_Refresh_CHG: 08004
Przyczyna
Należy odświeżyć tabelę zabezpieczeń w obszarze Dzienniki inspekcji (mxTableAccess — MXAT4001).
Rozwiązanie
Aby rozwiązać ten problem, możesz ponownie zainstalować dzienniki inspekcji w celu odświeżenia tabeli zabezpieczeń w następujący sposób:
Wybierz Microsoft Dynamics GP, wskaż Narzędzia, wskaż Firma, wskaż Dzienniki inspekcji, a następnie wybierz Zainstaluj dzienniki inspekcji.
W oknie Instalowanie dzienników inspekcji wybierz pozycję Zainstaluj.
W oknie Kreator instalacji wybierz pozycję Zainstaluj.
Wybierz Zakończ.
Więcej informacji
Ponowne instalowanie dzienników inspekcji spowoduje automatyczne przyznanie użytkownikom dostępu do baz danych inspekcji. Ponieważ dzienniki inspekcji są już zainstalowane dla firmy, instalacja zostanie zrealizowana i przejdzie do kroku 3 w Kreatorze instalacji, który przeprowadzi system przez proces dodawania nowych użytkowników do bazy danych. Nie spowoduje to zresetowania żadnych inspekcji ani żadnych ustawień, które są już skonfigurowane. Bieżące dane w tabelach inspekcji pozostaną nienaruszone.