Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
W tym artykule opisano problem, w którym AADSTS50011
podczas próby zalogowania się do aplikacji korzystającej z uwierzytelniania opartego na protokole OpenID Connect (OIDC) przy użyciu identyfikatora Entra firmy Microsoft jest zwracany komunikat o błędzie.
Symptomy
Podczas próby zalogowania się do aplikacji korzystającej z protokołów uwierzytelniania OIDC lub OAuth2 przy użyciu identyfikatora Entra firmy Microsoft jest wyświetlany następujący komunikat o błędzie:
Błąd AADSTS50011 — identyfikator URI <> przekierowania określony w żądaniu jest niezgodny z identyfikatorami URI przekierowania skonfigurowanymi dla identyfikatora APPGUID> aplikacji<. Upewnij się, że identyfikator URI przekierowania wysłany w żądaniu jest zgodny z identyfikatorem dodanym do aplikacji w Azure Portal. Przejdź do obszaru https://aka.ms/redirectUriMismatchError, aby dowiedzieć się więcej o tym, jak rozwiązać ten problem.
Przyczyna
Ten błąd występuje, jeśli identyfikator URI przekierowania (adres URL odpowiedzi) skonfigurowany w aplikacji (kod) i rejestracja aplikacji Entra firmy Microsoft nie są zgodne.
Gdy użytkownik uzyskuje dostęp do aplikacji do uwierzytelniania, aplikacja przekierowuje użytkownika do identyfikatora Microsoft Entra ID ze wstępnie zdefiniowanym identyfikatorem URI przekierowania. Po pomyślnym autoryzowanym użytkowniku identyfikator Entra firmy Microsoft weryfikuje następujące wartości:
- Identyfikator URI przekierowania wysłany z aplikacji
- Wartości identyfikatora URI przekierowania w zarejestrowanej aplikacji w identyfikatorze Entra firmy Microsoft
Jeśli identyfikator URI przekierowania wysłany przez aplikację nie jest zgodny z żadnymi identyfikatorami URI przekierowania w identyfikatorze Entra firmy Microsoft, zostanie zwrócony błąd AADSTS50011. Jeśli wartości są zgodne, identyfikator Entra firmy Microsoft wysyła użytkownika do identyfikatora URI przekierowania.
Rozwiązanie
Aby rozwiązać ten problem, wykonaj następujące kroki, aby dodać identyfikator URI przekierowania w rejestracji aplikacji Entra firmy Microsoft.
Skopiuj identyfikator aplikacji z komunikatu o błędzie. Jest to identyfikator aplikacji, która została zarejestrowana w identyfikatorze Entra firmy Microsoft.
Przejdź do portalu Azure Portal. Upewnij się, że logujesz się do portalu przy użyciu konta z uprawnieniami do aktualizowania rejestracji aplikacji Microsoft Entra.
Przejdź do pozycji Microsoft Entra ID, wybierz pozycję Rejestracje aplikacji, znajdź rejestrację aplikacji przy użyciu identyfikatora aplikacji, a następnie otwórz stronę rejestracji aplikacji.
Możesz również otworzyć stronę bezpośrednio, korzystając z następujących linków:
- Jeśli ta aplikacja jest własnością organizacji (dzierżawa firmy Microsoft Entra), użyj polecenia
https://portal.azure.com/#blade/Microsoft_AAD_RegisteredApps/ApplicationMenuBlade/Authentication/appId/<AppGUID>
. - Jeśli ta aplikacja jest własnością osobistego konta Microsoft (MSA), użyj polecenia
https://portal.azure.com/#blade/Microsoft_AAD_RegisteredApps/ApplicationMenuBlade/Authentication/appId/<AppGUID>/isMSAApp/true
.
- Jeśli ta aplikacja jest własnością organizacji (dzierżawa firmy Microsoft Entra), użyj polecenia
Na stronie rejestracji aplikacji wybierz pozycję Uwierzytelnianie. W sekcji Konfiguracje platformy wybierz pozycję Dodaj identyfikator URI, aby dodać identyfikator URI przekierowania wyświetlany w komunikacie o błędzie do identyfikatora Entra firmy Microsoft.
Zapisz zmiany i poczekaj od trzech do pięciu minut, aż zmiany zostaną wprowadzone, a następnie ponownie wyślij żądanie logowania. Teraz powinno być możliwe zalogowanie się do aplikacji. Jeśli nie widzisz strony logowania microsoft Entra, spróbuj wyczyścić pamięć podręczną haseł z przeglądarki lub użyć przeglądania InPrivate.
Uwaga 16.
Jeśli identyfikator URI przekierowania wysłany z aplikacji nie jest odpowiedni, należy zaktualizować kod aplikacji lub konfigurację.
W poniższym wideo pokazano, jak naprawić błąd niezgodności identyfikatora URI przekierowania w identyfikatorze Entra firmy Microsoft:
Więcej informacji
Aby uzyskać pełną listę kodów błędów uwierzytelniania i autoryzacji usługi Active Directory, zobacz Kody błędów uwierzytelniania i autoryzacji firmy Microsoft.
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.