Udostępnij za pośrednictwem


Dane firmowe niezapisane w aplikacjach dozwolonych przez funkcję WIP na urządzeniu hybrydowym firmy Microsoft Entra lub współzarządzaniu w usłudze Intune

Ten artykuł ułatwia rozwiązanie problemu, w którym nie można zapisywać danych firmowych w aplikacjach dozwolonych przez usługę WIP na urządzeniu z systemem Windows zarejestrowanym w usłudze Microsoft Intune za pośrednictwem hybrydowego dołączania hybrydowego firmy Microsoft Entra lub współzarządzania.

Symptomy

Rozważmy następujący scenariusz:

  • Używasz urządzenia z systemem Windows.
  • Urządzenie jest rejestrowane w usłudze Intune za pośrednictwem przyłączania hybrydowego firmy Microsoft lub współzarządzania programu Configuration Manager.
  • Do urządzenia są stosowane zasady funkcji Windows Information Protection (WIP).

W tym scenariuszu w przypadku korzystania z aplikacji dozwolonych przez funkcję WIP, takich jak Programy Microsoft Word i Microsoft Excel, występują następujące problemy:

  • Podczas próby zapisania dokumentu jako pliku roboczego zostanie wyświetlony następujący komunikat o błędzie:

    Program Word nie może ukończyć zapisywania z powodu błędu uprawnień do pliku.

    Zrzut ekranu przedstawiający błąd uprawnień do pliku.

  • Każdy plik pobrany z zasobów w chmurze jest automatycznie zapisywany jako Osobisty. Podczas próby zmiany pliku na Work zostanie wyświetlony następujący komunikat o błędzie:

    Nieoczekiwany błąd uniemożliwia stosowanie właściwości do pliku. Jeśli ten błąd będzie nadal wyświetlany, możesz użyć kodu błędu, aby wyszukać pomoc dotyczącą tego problemu.
    Błąd 0x8007177C: Zasady odzyskiwania skonfigurowane dla tego systemu zawierają nieprawidłowy certyfikat odzyskiwania.

    Zrzut ekranu przedstawiający 0x8007177C błędu.

  • Podczas próby utworzenia dokumentu roboczego zostanie wyświetlony następujący komunikat o błędzie: Program Word nie może ukończyć zapisywania.

    Zrzut ekranu programu Word nie może ukończyć błędu zapisywania.

Przyczyna

Te problemy występują, jeśli certyfikat agenta odzyskiwania danych systemu szyfrowania plików (EFS) w zasadach organizacji w zasadach grupy wygasł. W takim przypadku nie można zaszyfrować plików przy użyciu certyfikatu.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj poniższe kroki:

  1. Wyeksportuj stary certyfikat DRA i klucz prywatny, jeśli musisz odszyfrować pliki zaszyfrowane przy użyciu tego certyfikatu.
  2. Utwórz i zweryfikuj certyfikat SYSTEMU PLIKÓW DRA.
  3. Zaktualizuj zasady w zasadach grupy, aby używać nowego certyfikatu DRA.