Ustawienie wiadomości e-mail ochrony przed resetowaniem do ustawień fabrycznych nie jest wymuszane po zresetowaniu urządzenia z systemem Android Enterprise

Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że ustawienie wiadomości e-mail ochrony przed resetowaniem do ustawień fabrycznych nie działa zgodnie z oczekiwaniami dla zarejestrowanego urządzenia właściciela urządzenia z systemem Android Enterprise.

Symptomy

Rozpatrzmy następujący scenariusz:

  • Masz urządzenie z systemem Android Enterprise zarejestrowane w Microsoft Intune.

  • Ustawienie Wiadomości e-mail ochrony przed resetowaniem do ustawień fabrycznych jest włączone i podano adres e-mail, jak pokazano na poniższym zrzucie ekranu:

    Zrzut ekranu przedstawiający ustawienie ustawień wiadomości e-mail ochrony przed resetowaniem do ustawień fabrycznych i przykładowy adres e-mail.

  • Resetowanie do ustawień fabrycznych na urządzeniu jest resetowane za pośrednictwem menu Ustawienia (na przykład naciśnij pozycję Ustawienia>Ogólne zarządzanie>Resetuj>resetowanie danych do ustawień fabrycznych) lub czyścisz urządzenie z Intune w centrum administracyjnym Microsoft Intune.

W tym scenariuszu można aktywować urządzenie przy użyciu konta Google, które nie jest uwzględnione w ustawieniu wiadomości e-mail ochrony przed resetowaniem do ustawień fabrycznych .

Przyczyna

Ta sytuacja jest oczekiwana. Po zresetowaniu urządzenia do ustawień fabrycznych za pomocą menu Ustawienia lub wyczyszczeniu urządzenia z Intune w centrum administracyjnym Microsoft Intune wszystkie dane zostaną usunięte. Obejmuje to dane usługi Factory Reset Protection (FRP).

Rozwiązanie

Jedynym sposobem na zresetowanie urządzenia do ustawień fabrycznych bez utraty danych FRP jest tryb odzyskiwania.

Zalecamy ustawienie wartości Resetowanie do ustawień fabrycznych na wartość Blokuj , aby uniemożliwić użytkownikom korzystanie z opcji resetowania do ustawień fabrycznych w ustawieniach urządzenia.

Zrzut ekranu przedstawiający opcje resetowania do ustawień fabrycznych.

Następnie użyj jednej z następujących metod podczas resetowania urządzenia do ustawień fabrycznych:

  • Zresetuj urządzenie w trybie odzyskiwania.
  • Wyczyść urządzenie z Intune, gdy urządzenie jest w posiadaniu i oczekuje się, że zostanie zresetowane do dalszego użycia.