Błąd "Nie można odnaleźć tabeli wejściowej lub kwerendy" lub "źródło rekordu nie istnieje" podczas korzystania z programu Access

Oryginalny numer KB: 287696

Uwaga / Notatka

Wymaga podstawowych umiejętności w zakresie makr, kodowania i współdziałania. Ten artykuł dotyczy tylko bazy danych programu Microsoft Access (accdb i .mdb).

Objawy

Po otwarciu lub utworzeniu odwołania do połączonej tabeli w programie Microsoft Access może zostać wyświetlony jeden z następujących komunikatów o błędach:

  • Program Microsoft Office Access nie może odnaleźć obiektu "<name>".

  • Błąd czasu wykonywania "7874": Program Microsoft Office Access nie może odnaleźć obiektu "<name>".

Przyczyna

Ten komunikat o błędzie może zostać wyświetlony, jeśli program Access nie może odnaleźć tabeli lub zapytania w bazie danych, jeśli link wskazuje plik zewnętrzny, który nie istnieje, lub jeśli plik zewnętrzny został przeniesiony do nowej lokalizacji. Ten błąd może również wystąpić, jeśli usunięta lub przemianowana tabela albo kwerenda jest przywoływana na karcie Odnośnik w innej tabeli.

Rezolucja

Aby rozwiązać ten problem, wykonaj następujące czynności:

  • Sprawdź, czy tabela lub kwerenda istnieje. Jeśli nie istnieje, możesz usunąć wszystkie odwołania do niej lub jeśli jest to brakująca tabela, ponownie zaimportuj lub ponownie połącz tabelę. Jeśli brakuje zapytania, ponownie zaimportuj lub ponownie utwórz zapytanie. RecordSource Często właściwość formularza lub raportu zawiera odwołanie do tabeli lub kwerendy, której nazwa uległa zmianie lub która została usunięta.
  • Jeśli tabela lub zapytanie istnieje, prawdopodobnie w odwołaniu do niej występuje błąd składniowy lub błąd pisowni. Jeśli tak, popraw błąd składniowy lub błąd pisowni w odwołaniu.
  • Podczas próby otwarcia połączonej tabeli, tabela źródłowa może nie znajdować się w ścieżce określonej przez ciebie, gdy była połączona po raz pierwszy. Jeśli plik został przeniesiony, możesz użyć Połączonego Menedżera tabel, aby zaktualizować informacje o linku.