Udostępnij za pośrednictwem


Nie można rejestrować w środowisku VDI, takim jak Citrix lub RDP

Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że nie można rejestrować w środowisku infrastruktury pulpitu wirtualnego (VDI), takim jak Citrix lub Remote Desktop Protocol (RDP) w usłudze Microsoft aplikacja klasyczna Power Automate.

Dotyczy: Power Automate
Oryginalny numer KB: 4599050

Symptomy

Rejestrator pulpitu nie może identyfikować i uzyskiwać dostępu do elementów aplikacji, które są dostępne tylko za pośrednictwem środowiska VDI. Może to być citrix, RDP lub inne środowisko, które zwraca obraz pulpitu maszyny zdalnej.

Weryfikowanie problemu

aplikacja klasyczna Power Automate jest instalowany na komputerze lokalnym, ale aplikacja, którą próbujesz zautomatyzować, znajduje się na maszynie zdalnej.

Przyczyna

aplikacja klasyczna Power Automate mogą uzyskiwać dostęp do elementów aplikacji klasycznej programowo za pośrednictwem interfejsu programowania aplikacji (API). Jeśli jednak aplikacja jest dostępna tylko za pośrednictwem interfejsu VDI, aplikacja klasyczna Power Automate może uzyskać dostęp tylko do obrazu pulpitu maszyny zdalnej, a nie rzeczywistej aplikacji przechowywanej lokalnie.

Rozwiązanie

Aby rozwiązać ten problem, należy ręcznie skompilować przepływ pulpitu przy użyciu automatyzacji powierzchni. Typowe techniki automatyzacji powierzchni obejmują rozpoznawanie obrazów, automatyzację myszy i klawiatury oraz oczekiwanie na tekst na ekranie (OCR).