Nie można zarejestrować w środowisku VDI, takim jak Citrix lub RDP
Ten artykuł zawiera rozwiązanie problemu, w którym nie można rejestrować w środowisku infrastruktury pulpitu wirtualnego (VDI), takim jak Citrix lub Remote Desktop Protocol (RDP) w usłudze Microsoft aplikacja klasyczna Power Automate.
Dotyczy: Power Automate
Oryginalny numer KB: 4599050
Symptomy
Rejestrator pulpitu nie może identyfikować elementów aplikacji, które są dostępne tylko za pośrednictwem środowiska VDI, ani uzyskiwać do nich dostępu. Może to być środowisko Citrix, RDP lub dowolne inne środowisko, które zwraca obraz pulpitu maszyny zdalnej.
Weryfikowanie problemu
aplikacja klasyczna Power Automate jest zainstalowana na komputerze lokalnym, ale aplikacja, którą próbujesz zautomatyzować, znajduje się na komputerze zdalnym.
Przyczyna
aplikacja klasyczna Power Automate mogą programowo uzyskiwać dostęp do elementów aplikacji klasycznej za pośrednictwem interfejsu programowania aplikacji ułatwień dostępu (API). Jeśli jednak aplikacja jest dostępna tylko za pośrednictwem interfejsu VDI, aplikacja klasyczna Power Automate może uzyskiwać dostęp tylko do obrazu pulpitu maszyny zdalnej, a nie rzeczywistej aplikacji przechowywanej lokalnie.
Rozwiązanie
Aby rozwiązać ten problem, skompiluj przepływ pulpitu ręcznie przy użyciu automatyzacji powierzchni. Typowe techniki automatyzacji powierzchni obejmują rozpoznawanie obrazów, automatyzację myszy i klawiatury oraz oczekiwanie na tekst na ekranie (OCR).