Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Ten artykuł pomaga rozwiązać problem polegający na tym, że przepływ kończy się niepowodzeniem z powodu błędu "Nie znaleziono pulpitu zdalnego" podczas korzystania z protokołu RDP (Remote Desktop Protocol) firmy Microsoft lub automatyzacji Citrix w usłudze Microsoft Power Automate.
Objawy
Przepływ korzystający z protokołu RDP (Remote Desktop Protocol) lub automatyzacji Citrix, który wcześniej działał pomyślnie, może zacząć mieć awarie z następującym błędem:
Nie można odnaleźć pulpitu zdalnego.
Ten problem jest częściej spotykany w usłudze Citrix Virtual Apps.
Przyczyna 1
Nazwy okna protokołu RDP, Citrix Desktop lub Citrix Virtual Apps mogły ulec zmianie od czasu przechwycenia oryginalnych elementów interfejsu użytkownika . Śledzenie tych elementów przy użyciu starej nazwy może zakończyć się niepowodzeniem.
Rezolucja
Aby rozwiązać ten problem:
Upewnij się, że objęte okno RDP, Citrix Desktop lub Citrix Virtual Apps jest aktywne.
Znajdź element pulpitu powodujący problem w okienku elementów interfejsu użytkownika w narzędziu do projektowania procesu. Kliknij go dwukrotnie, aby otworzyć edytor selektora.
Wybierz przycisk Napraw i przechwyć nowy pulpit lub aplikację. Przejrzyj sugerowane zmiany i zaakceptuj je. Aby uzyskać więcej informacji, zobacz Naprawianie selektora.
Po zaakceptowaniu zmian wybierz pozycję Testuj , aby zweryfikować nowy selektor. Aby uzyskać więcej informacji, zobacz Testowanie selektora.
(Opcjonalnie) Użyj przycisku Nowy, aby dodać więcej selektorów zapasowych dla pulpitu.
Przyczyna 2
W przypadku korzystania z aplikacji Citrix Virtual Apps z określonymi aplikacjami, zwłaszcza podczas interakcji z listami pól kombi, można utworzyć niepoprawny selektor pulpitu docelowego przy użyciu wartości porządkowej (na przykład eq) zamiast bardziej niezawodnej metody wyboru.
Rezolucja
Aby rozwiązać ten problem:
Upewnij się, że objęte okno RDP, Citrix Desktop lub Citrix Virtual Apps jest aktywne.
Znajdź element pulpitu, który powoduje problem, w panelu Elementy interfejsu użytkownika w projektancie przepływu. Kliknij go dwukrotnie, aby otworzyć edytor selektora.
Sprawdź, czy selektor używa wartości porządkowej ( eq jest zaznaczone ). Jeśli tak jest, wyczyść wartość i zapisz zmianę.
Wybierz pozycję Testuj , aby zweryfikować nowy selektor. Aby uzyskać więcej informacji, zobacz Testowanie selektora.
Zastrzeżenie dotyczące informacji pochodzących od stron trzecich
Produkty innych firm omówione w tym artykule są produkowane przez firmy, które są niezależne od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, dorozumianych ani żadnego innego rodzaju, w odniesieniu do wydajności lub niezawodności tych produktów.