Udostępnij za pośrednictwem


Sporadyczne błędy połączenia występują podczas dodawania węzła do środowiska Zawsze włączone w SQL Server

Występują sporadyczne błędy połączenia podczas dodawania nowego węzła do istniejącego środowiska Zawsze włączone.

Symptomy

Podczas próby nawiązania połączenia z serwerem z uruchomioną usługą Microsoft SQL Server sporadycznie pojawia się następujący komunikat o błędzie:

Połączenie zostało pomyślnie nawiązane z serwerem, ale wystąpił błąd podczas procesu logowania. (dostawca: dostawca protokołu SSL, błąd: 0 — istniejące połączenie zostało wymuszone przez hosta zdalnego).

Przyczyna

Ten błąd może wystąpić, jeśli występuje niezgodność protokołów zabezpieczeń między bazą danych a serwerami aplikacji.

Rozwiązanie

Aby naprawić ten błąd, rozwiąż niezgodność między protokołami zabezpieczeń. Węzeł Node1 szyfruje informacje przy użyciu protokołu AES128/256. Węzeł Node2 szyfruje informacje przy użyciu RC4. Aby rozwiązać ten błąd, wykonaj następujące kroki:

  1. Pobierz usługę IIS Crypto.

  2. Zainstaluj na serwerze wersję graficznego interfejsu użytkownika narzędzia kryptografii usług IIS.

  3. Skonfiguruj pakiety szyfrowania.

  4. Otwórz narzędzie kryptograficzne usług IIS na serwerze.

  5. W interfejsie kryptograficznym usług IIS wybierz pozycję Zestawy szyfrowania w panelu po lewej stronie.

  6. Na liście wyczyść wszystkie pola wyboru dla szyfrów rozpoczynających się od "TLS_DHE*".

    Uwaga

    Lista może nie być w żadnej konkretnej kolejności.

  7. Po wyczyszczeniu odpowiednich wyborów szyfrowania wybierz pozycję Zastosuj , aby zapisać zmiany.

    Zrzut ekranu przedstawiający wyczyszczenie wszystkich szyfrowaniy, które nie są wymagane.

  8. Uruchom ponownie serwer.

    Po zastosowaniu zmian uruchom ponownie serwer, aby upewnić się, że nowa konfiguracja zestawu szyfrowania zostanie zastosowana.

Uwaga

Ten proces rozwiązywania problemów wymusza na kliencie komunikowanie się przy użyciu innego zestawu szyfrowania, który ma ulepszoną implementację zabezpieczeń.

Zawsze upewnij się, że dostępne są odpowiednie kopie zapasowe. Należy również rozważyć przetestowanie wszelkich zmian w kontrolowanym, przygotowanym lub testowym środowisku przed zastosowaniem ich do komputerów produkcyjnych. Jeśli problem będzie się powtarzać lub masz inne wątpliwości, skontaktuj się z zespołem ds. sieci.

Zastrzeżenie dotyczące innych firm

Produkty innych firm omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, dorozumianych ani żadnego innego rodzaju, w odniesieniu do wydajności lub niezawodności tych produktów.

Wyłączenie odpowiedzialności za kontakty z osobami trzecimi

Firma Microsoft udostępnia informacje kontaktowe innych firm, które ułatwiają znalezienie dodatkowych informacji na ten temat. Informacje te mogą zostać zmienione bez powiadomienia. Firma Microsoft nie gwarantuje dokładności informacji kontaktowych innych firm.