Błędy podsystemu zabezpieczeń lokalnych w programie SQL Server
Ten artykuł pomaga rozwiązać problem z uwierzytelnianiem spójnym podczas nawiązywania połączenia z programem SQL Server, który jest związany z nieodpowiednioną usługą podsystemu lokalnego urzędu zabezpieczeń (LSASS).
Symptomy
Mogą wystąpić problemy z podsystemem zabezpieczeń związane z usługą LSASS. Sterownik uwierzytelniania systemu Windows może wyświetlać komunikat o błędzie "Identyfikator logowania pochodzi z niezaufanej domeny i nie może być używany z uwierzytelnianiem systemu Windows".
Sprawdź, czy w dzienniku błędów programu Microsoft SQL Server są wyświetlane następujące wpisy:
Uzgadnianie interfejsu SSPI nie powiodło się z kodem błędu 0x80090311, stan 14 podczas nawiązywania połączenia ze zintegrowanymi zabezpieczeniami; połączenie zostało zamknięte. Przyczyna: Nie można zaakceptowaćzabezpieczeniaKontekstu. Kod błędu systemu Windows wskazuje przyczynę błędu.
Uzgadnianie interfejsu SSPI nie powiodło się z kodem błędu 0x80090304, stan 14 podczas nawiązywania połączenia ze zintegrowanymi zabezpieczeniami; połączenie zostało zamknięte. Przyczyna: Nie można zaakceptowaćzabezpieczeniaKontekstu. Kod błędu systemu Windows wskazuje przyczynę błędu.
Błędy protokołu Kerberos mogą również występować w dzienniku zdarzeń systemowych na serwerze z uruchomionym programem SQL Server w tym samym zakresie czasu. Poniższy kod błędu wskazuje:
Błąd — 2146893039 (0x80090311): Nie można skontaktować się z żadnym urzędem w celu uwierzytelnienia.
Przyczyna
Te błędy występują, gdy LSASS przestaje odpowiadać.
Rozwiązanie
Aby rozwiązać problemy z błędami LSASS, wykonaj następujące kroki:
Sprawdź, czy główna nazwa usługi (SPN) jest poprawnie zarejestrowana na kontrolerze domeny (DC).
setspn -Q
Użyj polecenia lubsetspn -L
, aby wykonać zapytanie względem nazwy SPN i nazw SPN odpowiednio na koncie.